C++ PAT甲级 1023 Have Fun with Numbers (20分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:
For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899

      
    
Sample Output:
Yes
2469135798
#include <iostream>
#include <string>
using namespace std;
int main()
{
    string N;
    cin >> N;
    int doub[21]={0};
    int len=N.length();
    int j=0;
    int a[10]={0},b[10]={0};
    int flag=0;
    for (int i=len-1;i>=0;i--)//计算doub
    {
        int t=N[i]-'0';
        a[t]++;//N每位数的个数
        int n=doub[j]+t*2;
        if (n<10) doub[j]=n;
        else
        {
            doub[j]=n%10;
            doub[j+1]=n/10;
        }
        j++;
        if (i==0 && n>=10) j++;//第一位需进1的情况
    }
    for (int i=0;i<j;i++)
    {
        b[doub[i]]++;//doub每位数的个数
    }

    for (int i=0;i<10;i++)
    {
        if(a[i]==b[i]) continue;
        else
        {flag=1;break;}
    }
    if (flag==0) cout <<"Yes";
    else cout <<"No";
    cout << endl;
    for (int i=j-1;i>=0;i--)
    cout << doub[i];
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值