2-D-splice
题目
splice
For n lists Li (i=0,1,…,n−1), perform a sequence of the following operations.
insert(t, x): Insert an integer x at the end of Lt.
dump(t): Print all elements in Lt.
splice(t): Transfer elements of Ls to the end of Lt. Ls becomes empty.
In the initial state, all stacks are empty.
输入
The input is given in the following format.
n q
query1
query2
:
queryq
Each query queryi is given by 0 t x or 1 t or 2 s t where the first digits 0, 1 and 2 represent insert, dump and splice operations respectively. 1≤n≤1,000 1≤q≤500,000 ,For a splice operation, s≠t For a splice operation, Ls is not empty The total number of elements printed by dump operations do not exceed 1,000,000 −1,000,000,000≤x≤1,000,000,000
输出
For each dump operation, print elements of the corresponding list in a line. Separete adjacency elements by a space character (do not print the space after the last element). Note that, if the list is empty, an empty line should be printed.
样例输入
3 10
0 0 1
0 0 2
0 0 3
0 1 4
0 1 5
2 1 0
0 2 6
1 0
1 1
1 2
样例输出
1 2 3 4 5
6
题解(代码流程)
#include<bits/stdc++.h>
#include<iostream>
using namespace std;
int main() {
ios::sync_with_stdio(false);
cin.tie(nullptr);
cout.tie(nullptr);
int n, q;
cin >> n >> q;
vector<list<int>> L(n);//定义嵌套链表数组
while (q--) {
int p;
cin >> p;
if (p == 0) {
int t, x;
cin >> t >> x;
L[t].insert(L[t].end(), x);//把x放入L[t]末尾
} else if (p == 1) {
int t;
cin >> t;
for (auto e: L[t]) {
cout << e << " ";//输出整个链表L[t]
}
cout << endl;
} else if (p == 2) {
int s, t;
cin >> s >> t;
L[t].splice(L[t].end(), L[s]);//本题重点splice拼接链表
}
}
return 0;
}
小结
学会运用splice来拼接链表达到目标需求。
remember
splice实现list拼接的功能
splice(iterator position,list<T,Allocator>&x)