Balanced Lineup

For the daily milking, Farmer John’s N cows (1 ≤N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input
Line 1: Two space-separated integers, N and Q.
Lines 2… N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2… N+ Q+1: Two integers A and B (1 ≤ A ≤B ≤ N), representing the range of cows from A to Binclusive.

Output
Lines 1… Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output
6
3
0

题意
给定一个序列,每次查询区间内max-min的差

思路
单点更新,求最值

代码

#include<iostream>
#include<algorithm>
using namespace std;
const int INF=0xffffff0;
const int maxn=50010;
struct node
{
	int l,r,min1,max1;
}tree[4*maxn];
int a[maxn],max1,min1; 
void build(int t,int l,int r)//建树并赋值
{
	tree[t].l=l;
	tree[t].r=r;
	if(l==r)
	{
		tree[t].max1=tree[t].min1=a[l];
		return ;
	}
	int mid=(tree[t].l+tree[t].r)/2;
	build(2*t,l,mid);
	build(2*t+1,mid+1,r);
	tree[t].min1=min(tree[2*t].min1,tree[2*t+1].min1);//左右树的最大值和最小值
	tree[t].max1=max(tree[2*t].max1,tree[2*t+1].max1);   
}
void query(int t,int s,int e)//查询
{
	if(min1<=tree[t].min1&&max1>=tree[t].max1)
		return;
	if(tree[t].l==s&&tree[t].r==e)//区间相等
	{
		min1=min(min1,tree[t].min1);
		max1=max(max1,tree[t].max1);
		return ;
	}
	int mid=(tree[t].l+tree[t].r)/2;
	if(e<=mid)//在左树
		query(2*t,s,e);
	else if(s>mid)//在右树
		query(2*t+1,s,e);
	else//被分割
	{
		query(2*t,s,mid);
		query(2*t+1,mid+1,e);
	}
}
int main()
{
	int n,q,num,s,e;
	scanf("%d%d",&n,&q);
	for(int i=1;i<=n;i++)
		scanf("%d",&a[i]);
	build(1,1,n);
	for(int i=1;i<=q;i++)
	{
		min1=INF;
		max1=-INF;
		scanf("%d%d",&s,&e);
		query(1,s,e);
		printf("%d\n",max1-min1);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值