2021-03-13

HDU 1083(二分图匹配\匈牙利算法)

题目链接

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 … Student1 Count1
Count2 Student2 1 Student2 2 … Student2 Count2

CountP StudentP 1 StudentP 2 … StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you’ll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line “YES” if it is possible to form a committee and “NO” otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

Code

#include<iostream>
#include<cstring>
using namespace std;
int MAP[520][520];//第i节课和第j个学生的联系
int vis[520];//作为标记是否被访问
int link[520];//第i节课被第link[i]个学生选中
int P,N;//p节课,n个学生
bool find(int x)
{
    for(int i=1;i<=N;i++)
    {
        if (MAP[x][i]&&vis[i]==0)//第x节课和第i个学生之间有联系,在这里就是第i个学生选了第x节课,可以看main()函数里面的实现||第i节课没有被访问
        {
            vis[i]=1;//进行了访问,进行标记
            if (link[i]==0||find(link[i]))//第i个学生没有选课或者第i个学生选的第link[i]节课可以换成其他学生
            {
                link[i]=x;//对第i个学生选的第link[i]节课进行更新
                return true;//第x节课可以被学生匹配到,就返回true
            }
        }
    }
    return false;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        memset(MAP,0,sizeof(MAP));//每次进行新的一组测试数据时都要情况MAP[][]数组
        cin>>P>>N;//按照题目要求输入P和N;P节课和N个学生
        for(int i=1;i<=P;i++)
        {
            int temp;
            cin>>temp;//有temp个学生选了第i节课
            for(int j=1;j<=temp;j++)
            {
                int y;
                cin>>y;
                MAP[i][y]=1;//第y个学生选了第i节课
            }
        }
        int ans=0;//定义变量并赋初值为零
        memset(link,0,sizeof (link));//情况link[]数组
        for(int i=1;i<=P;i++)
        {
            memset(vis,0,sizeof (vis));//每次循环要把vis数组情况
            if (find(i)) ans++;//如果第i节课可以被选到就对ans++;
        }

        if (ans==P) cout<<"YES\n";//所有课程全部都有学生选,那么就满足题目要求
        else cout<<"NO\n";
    }

    return 0;
}

具体的我已经写在注释里面了,这也算是比较简单的一道二分图匹配吧;

有问题请多多指教,我也是小白一个;

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值