BFS问题: Catch That Cow

一道BFS问题,找最快使用BFS,到达相应位置立即停止

题目描述

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

输入

multi test case.

For each test case, contains two space-separated integers: N and K


 

输出

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

样例输入 

5 17
6 18

样例输出

4
4

提示

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include <bits/stdc++.h>
using namespace std;
int n,des;
int visited[100007];
int b[100007];//表示已移动的次数

void BFS(int n,int des){
    //找最快使用BFS,到达相应位置立即停止
    memset(visited,0,sizeof(visited));
    memset(b,0,sizeof(b));
    queue<int> que;
    que.push(n);
    visited[n] = 1;
    b[1] = 0;
    while(!que.empty()){
        int q = que.front();
        que.pop();
        if(q == des){
            cout<<b[q]<<endl;
            return;
        }
        else{
        //走一格
        if(!visited[q + 1]&&q+1>=0&&q +1 <= 100000){
            visited[q + 1] =1;
            b[q+1] = b[q] + 1;
            que.push(q+1);
        }
        //退一格
        if(!visited[q - 1]&&q-1>=0&&q -1 <=100000){
            visited[q-1] =1;
            b[q-1] = b[q] + 1;
            que.push(q-1);
        }
        //传送
        if(!visited[q*2]&&q*2>=0&&q*2 <= 100000){
            visited[q * 2] =1;
            b[q*2] = b[q] + 1;
            que.push(q*2);
            }
        }
    }
}
int main()
{
    while(cin>>n>>des){
        BFS(n,des);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值