B - Catch That Cow(BFS)

简单、BFS,注意的是因为有-1,所以状态会有返回并反复将相同的状态装入队列的情况,为了增加效率,防止内存超出,应该标记每次所经历过的状态,防止对同一个状态的多次访问。

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>

using namespace std;

int n, k;
//int cnt = 0;
int d[100005];
int vis[100005];
int bfs(void)
{
    memset(d, -1, sizeof(d));
    memset(vis, 0, sizeof(vis));
    if(n == k)
        return 0;
    queue<int> que;
    que.push(n);
    d[n] = 0;
    vis[n] = 1;
    while(que.size())
    {
        int q = que.front();
        que.pop();
        if(q == k)
            break;
        if(2 * q < 100005 && vis[2*q] == 0)
        {
            d[2 * q] = d[q] + 1;
            vis[2*q] = 1;
            que.push(2*q);
        }
        if(q + 1 < 100005 && vis[q+1] == 0)
        {
            d[q+1] = d[q] +1;
            vis[q+1] = 1;
            que.push(q+1);
        }
        if(q - 1 >= 0 && vis[q-1] == 0)
        {
            d[q-1] = d[q] +1;
            vis[q-1] =1;
            que.push(q-1);
        }
    }

    return d[k];
}

int main()
{
    cin>>n>>k;
    int cnt = bfs();
    cout<<cnt<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值