题目描述
新春过后的第一次比赛,相信大家都已经准备好了。那么就为大家热下身吧。问题很简单,对一组输入的数据进行排序。 对输入的数据,我们有如下的约定:所有的输入数据都为正整数,且都不大于300000000。但是输入的数据可能会有重复,排序时,应将重复的数据合并,即同样的数只处理一次。
输入
只有一组数据,以0结尾。
输出
输出排序后的数据(不含0),其中相同的数应只显示1个。
样例输入 Copy
1 2 2 3 2 3 4 0
样例输出 Copy
1 2 3 4
提示
注意:相邻数之间有一个空格,最后一个数换行(后面没有空格)。
# include <iostream>
using namespace std;
# include <set>
int main()
{
set<int> v;
int a;
while (cin >> a, a)
{
v.insert(a);
}
set<int>::iterator it;
for (it = v.begin(); it != v.end(); it++)
{
if (it == v.begin())
cout << *it;
else
cout << " " << *it;
}
cout << endl;
return 0;
}