PAT甲级 1038 Recover the Smallest Number (30 point(s))

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤104) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

题意:求最小组成数

样例:有5个数,分别是32,321,3212,0229,87,用这五个数组成最小的数,前导零不要

收获:①删除字符串首位元素 s.erase(s.begin());

           ②数字字符串求最小组成数的排序,return a+b<b+a,保证两两组成的数是最小的,从而最后组成的字符串是最小组成数(贪心体现在这里),不是按字典顺序排列;

代码:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
bool cmp(string s1,string s2){
	return s1+s2<s2+s1;//两两组成数最小,才能使结果最小;
}
int main(){
	int n;
	string str;
	cin>>n;
	vector<string >s(n);
	for(int i=0;i<n;i++){
		cin>>s[i];
	}
	sort(s.begin(),s.end(),cmp);
	for(int i=0;i<n;i++){
		str+=s[i];
	}
	while(str.size()!=0&&str[0]=='0'){	//去掉前导零的情况;
		str.erase(str.begin());
	}
	if(str.size()==0){
		cout<<"0";
	}else cout<<str;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值