PAT 1054 The Dominant Color

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

题意:给出一个5*3的矩阵,找出矩阵内超过矩阵内数的一半且出现次数最多的数,即24;

思路:

因为输入的数据(16777215,1*10^7)有大于int最大范围(整型的最大范围是8388608,即8*10^6),所以这里不能用数组的散列表,应该用map作为散列表,在map中用find函数,如果找得到就次数++,找不到就说明之前不存在这个数,置为1,最后遍历map,找到次数最多的那个输出就好了

学习:

1.map的定义不需要开大小范围

2.map的遍历,for(map<类型,类型>::iterator it=map.begin();it!=map.end();it++)

3.map的key和value的访问,key:it->first,value:it->second;

代码:

//map的使用;
//题目说输入的数的范围最大是到2^24,已经超过了int的最大范围,用散列表开这么大可能会超空间,所以这里用的是map; 
#include<iostream>
#include<map>
using namespace std;
int main(){
	int n,m,num;
	scanf("%d %d",&n,&m);
	map<int ,int > count;
	for(int i=0;i<n;i++){//不要直接用n*m,两个整型数相乘容易溢出; 
		for(int j=0;j<m;j++){
			scanf("%d",&num); 
			if(count.find(num)!=count.end()){//若存在则计数,不在则创建并置为1; 
				count[num]++;
			}else {
				count[num]=1;
			}
		}
	}
	int max=-1;
	for(map<int,int>::iterator it=count.begin();it!=count.end();it++){//迭代方式
	//for(类型::iterator it=类型.begin(),it!=类型.end();it++) 
		if(it->second>max){
			max=it->second;//it就可以代表map的一个项; 
			num=it->first;
		}
	}
	printf("%d",num);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值