PAT 甲级 1022 Digital Library

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

题意:输入三本数,然后输入书本的信息,分别是书的编号,书名,作者名,关键词信息,出版商,发行事件,后面都按这个顺序输入各个书本的信息,6次查询,查询的格式中的数字代表着是什么样的信息(1是书名,2是作者名,3是关键词,4是出版商,5是出版事件),我们要根据信息查询是否存在这个书,是就输出其编号否则输出Not Found,在寻找书本之前还要原样输出书本查询的格式信息。

思路:作5个map<string,set<int>>,将书名,作者名,关键词等和书的编号作映射,从而通过这些信息查得到书的编号.

代码:

#include<iostream>
#include<map>
#include<set>
using namespace std;
void query(map<string,set<int > > &m,string &s){//字符串以map的参数传递速度较慢,如果不用引用,最后一个测试点就会超时,我的理解是引用传的是地址,而直接传参是传入map的复制, 
	if(m.find(s)==m.end()){
		cout<<"Not Found"<<"\n";
	}else {
		for(set<int>::iterator it=m[s].begin();it!=m[s].end();it++){//遍历的是m[s]位置下的set容器,所以迭代器应该是set而不是map<string,set<int > >; 
			printf("%07d\n",*it);
		}
	}
}
int main(){
	int n,m,id,num;
	string bookname,author,keyword,print,word,year,str;
	map<string,set<int> > mapName,mapAuthor,mapKey,mapYear,mapPrint;
	cin>>n;
	getchar();
	for(int i=0;i<n;i++){
		cin>>id;
		getchar();//吸收cin留下的回车; 
		getline(cin,bookname);
		mapName[bookname].insert(id);
		getline(cin,author);
		mapAuthor[author].insert(id);
		while(cin>>word){//遇到空格或者回车就会结束输入,跳过空格,直到遇到下一次有效cin,直到全部输入完毕,从而实现单词分离; 
			mapKey[word].insert(id);
			char c=getchar();
			if(c=='\n')break;
		}
		getline(cin,print);
		mapPrint[print].insert(id);
		getline(cin,year);
		mapYear[year].insert(id);
	}
	cin>>m;
	for(int i=0;i<m;i++){
		scanf("%d: ",&num);//scanf()函数是通用终端格式化输入函数,它从标准输入设备(键盘) 读取输入的信息。可以读入任何固有类型的数据并自动把数值变换成适当的机内格式。
		//即按格式输入这部分信息,不影响后面信息读取; 
		getline(cin,str);
		cout<<num<<": "<<str<<"\n";
		if(num==1){//说明输入的是书名; 
			query(mapName,str);
		} else if(num==2){//查询作者名字; 
			query(mapAuthor,str);
		}else if(num==3){//关键词; 
			query(mapKey,str);
		}else if(num==4){
			query(mapPrint,str);
		}else {
			query(mapYear,str);//查询年限; 
		}
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值