A1022 Digital Library (30 分)PAT (Advanced Level) Practice甲级(C++)满分题解【非map】

该博客讨论了一种高效的方法来管理和检索大型数字图书馆中的书籍信息。文章中提到,原本打算使用结构体来实现,但考虑到效率问题,选择了使用vector结合map来优化。输入包括书籍的ID、标题、作者、关键词、出版商和出版年份,通过多种查询方式进行检索。输出则按照查询类型和书籍ID的升序排列。博客中提到了输入字符串处理的注意事项,如 cin.ignore() 的使用以及处理冒号后的空格等细节问题。
摘要由CSDN通过智能技术生成

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

一看到这道题第一反应本来是打算用结构体做的,但是结构体的话不好将属性编号来对内容进行索引,需要遍历很多次,后面可能会运行超时。

网上也有很多大神用map做的,我这里是直接用vector存结果边判断边直接输出了。

这道题比较需要注意的是,由于输入的字符串中含有空格,而一般的cin和scanf是滤过空格的,容易导致错误。还有要注意的是(因为这个折腾了很久),在用cin输入书本数量后,缓冲区存了一个换行符,所以往下直接使用getline的话,就把那个换行符输出了,导致后面的数据都错位了,所以解决方法是先用cin.ignore(1),忽略那个碍事的换行符。还有一个坑就是用户查询的条目里,冒号后面也是有一个空格的,也需要滤去。都是血泪史。。。

代码如下:

#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
using namespace std;
int main()
{
    //输入每本书的信息
    int n;//书数
    cin>>n;
    cin.ignore(1);//忽略缓冲区的空格
    vector<vector<string>> booklist(n);
    for(int i=0;i<n;i++)
        for(int j=0;j<6;j++){
            string in;//由于包含空格,%s是滤过空格的,不能用scanf
            getline(cin,in);
            booklist[i].push_back(in);
        }
    int m;//查询数
    cin>>m;
    for(int i=0;i<m;i++)
    {
        int queryId;
        string queryContent;
        char c;
        vector<string> ans;
        cin>>queryId>>c;
        cin.ignore(1);//忽略冒号后的空格
        getline(cin,queryContent);
        cout<<queryId<<c<<" "<<queryContent<<endl;
        //除了keywords,其他都是直接输出对应内容即可
        //输入查询内容与书库匹配
        for(int j=0;j<n;j++)
        {
            if(queryId==3){
                if(booklist[j][3].find(queryContent)!=string::npos)
                    ans.push_back(booklist[j][0]);
            }
            else{
                if(booklist[j][queryId]==queryContent)
                    ans.push_back(booklist[j][0]);
            }
        }
        //没找到输出
        if(ans.size()==0){
            cout<<"Not Found\n";
            continue;
        }
        //书编号按从小到大输出
        sort(ans.begin(),ans.end());
        for(auto it=ans.begin();it!=ans.end();it++)
            cout<<*it<<endl;
    }
    return 0;
}

运行结果如下:

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值