PAT 甲级 1100 Mars Numbers

ople on Mars count their numbers with base 13:

  • Zero on Earth is called "tret" on Mars.
  • The numbers 1 to 12 on Earth is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

思路:这道题的本质就是数字和字符串的映射,即字符串映射数字,数字映射字符串,数字映射字符串用一个字符串数组就可以了,字符串数组的下标代表其数字,内容存放字符串,字符串映射数字的话用map,数字处理分三种情况,13的倍数,小于13的数,前二者均是一位数的情况,然后是两位数的情况;

代码:

#include<iostream>
#include<cmath>
#include<map>
#include<cctype>
using namespace std;
string num1[13]={"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string num2[13]={"tret","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
string numTostr[170];//这一题的本质就是数字映射字符串,字符串映射数字,前者用字符串数组即可,后者用map; 
map<string,int > strTonum;
void find_form(){//用打表法将所有映射表达出来; 
	for(int i=0;i<13;i++){//特殊情况,即高位有数低位没数,高位没数低位有数,和0; 
		numTostr[i]=num1[i];
		strTonum[num1[i]]=i;
		numTostr[i*13]=num2[i];
		strTonum[num2[i]]=i*13;
	}
	for(int i=1;i<13;i++){
		for(int j=1;j<13;j++){//高位低位都有数,即两位数的情况; 
			string str=num2[i]+" "+num1[j];//这里不要写反Num2,num1的位置,num2才是高位; 
			numTostr[i*13+j]=str;
			strTonum[str]=i*13+j;
		}
	}
}
int main(){
	int n;
	find_form();//永远不要忘记打表!永远不要忘记打表!永远不要忘记打表!; 
	cin>>n;
	getchar();
	for(int i=0;i<n;i++){
		string str;
		getline(cin,str);
		if(isdigit(str[0])==true){
			int num=0;
			for(int i=0;i<str.length();i++){
				num=num+(str[str.length()-1-i]-'0')*pow(10,i);
			}
			cout<<numTostr[num]<<"\n";
		}else {
			cout<<strTonum[str]<<"\n";
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值