PAT甲级 1032 Sharing(25) (链表)

题目

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

输入

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10^{5}), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

输出

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

样例输入 

样例输入1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

样例输入2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

样例输出 

样例输出1:

67890

样例输出2:

-1

题意理解

给你两个用链表存储的单词 从前往后看找到第一个不同位置的节点编号 也就是地址address

先给你两个头节点的地址 和 n个节点信息

每个节点信息是节点地址 节点数据  节点的下一个节点地址

如果找到第一个共用的节点 那么输出共用节点地址 否则输出-1

那么我们直接用链表来写 采用头插法 插入两个虚拟头节点 h1和h2 方便我们从后往前找的时候方便退出

如果找到了那就是不一样的地址 (有可能结点值一样) 那么我们就输出

注意这里一开始将虚拟头结点设置成不一样的地址 这样就算我们找到头也一定会不一样的

如果一开始就不一样那么直接输出-1即可

代码 

#include<bits/stdc++.h>
using namespace std;
const int N=2e5+10;
const int INF=0x3f3f3f3f;
typedef struct Node {
	int address,next;
	string data;
} Node;
Node ta[N];
vector<Node>w1,w2;
int main() {
	int a,b;
	int n;
	cin>>a>>b>>n;
	for(int i=0; i<n; i++) {
		int add;
		cin>>add;
		ta[add].address=add;
		cin>>ta[add].data>>ta[add].next;
	}
	Node h1,h2;
	h1.address=INF;
	h2.address=-INF;
	w1.push_back(h1);
	w2.push_back(h2);
	
	for(int i=a; i!=-1; i=ta[i].next) {
		w1.push_back(ta[i]);
	}
	for(int i=b; i!=-1; i=ta[i].next) {
		w2.push_back(ta[i]);
	}

	auto it1=w1.end()-1;
	auto it2=w2.end()-1;

	while(it1->address==it2->address) {
		it1--;
		it2--;
	}
    if(it1==w1.end()-1||it2==w2.end()-1)puts("-1");
    else printf("%05d\n",(it1+1)->address);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值