PAT-甲级-1053 Path of Equal Weight (30 分)

60 篇文章 0 订阅

1053 Path of Equal Weight (30 分)

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to Lis defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题目大意:给定一棵路径树,输出一条路径,该路径权重和与给定数字相等,且有多条时按权重非递减输出;

解题思路:

  • 用二维数组保存树;
  • 每个子树的父节点对应的孩子都按照其权重非递减排序后再放入二维数组中;
  • dfs的边界条件有两个,第一个为剪枝条件:当前路径的权重和已经超出给定数字时返回;
    第二边界条件是:当前路径权重与给定数字相等,且当前结点为叶子节点;
  • dfs的参数是:当前要访问结点、当前路径的权重和;
  • 每次遍历子树父节点的孩子结点,当子树父节点遍历完时,要将其push_back出路径。 
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
#define rep(i,j,k)    for(int i=j;i<k;i++)

void read(){
    freopen("in.txt","r",stdin);
    freopen("out.txt","w",stdout);
}
struct node{
    int wei,id;
}no[110];
vector<vector<node>> v;
vector<int> wei,path;
int sum;
bool cmp(node a,node b){
    return a.wei > b.wei;
}
void dfs(int u,int ans){
    if(ans>sum)    return;
    if(ans==sum && v[u].size() == 0){
        int len = path.size();
        rep(i,0,len)
        printf("%d ",path[i]);
        printf("%d\n",no[u].wei);
    }
    path.push_back(no[u].wei);
    int vlen = v[u].size();
    rep(i,0,vlen)
    dfs(v[u][i].id,ans+v[u][i].wei);
    path.pop_back();
}
int main(){
    read();
    int n,m,a,b,k;
    cin>>n>>m>>sum;
    wei.resize(n);
    v.resize(n);
    rep(i,0,n){
        cin>>no[i].wei;
        no[i].id = i;
    }
    rep(i,0,m){
        cin>>a>>k;
        vector<node> tmp(k);
        rep(j,0,k){
            cin>>b;
            tmp[j] = no[b];
        }
        sort(tmp.begin(),tmp.end(),cmp);
        v[a] = tmp;
    }
    dfs(0,no[0].wei);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值