PAT 甲级 A1064 Complete Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题意:给定n个结点的权重(不是插入顺序),求该完全二叉查找树的层序遍历;

给出n个数,如何建造一个完全二叉查找树?

  1. 完全二叉树可以用数组来表示,数组值为权值,下标为结点编号,根节点的编号为1,左孩子为2*x,右孩子为2*x+1。
  2. 根据二叉查找树的性质,二叉查找树的中序遍历是有序的,对序列进行排序后,从根结点开始对该完全二叉树进行中序遍历,并将该序列补充到该完全二叉树,从而得到一颗完全二叉查找树。

完全二叉树->完全二叉查找树

先得是一颗完全二叉树,才能是一颗完全二叉查找树

代码:
 

#include<iostream>
#include<algorithm>

using namespace std;
const int Maxn = 10010;
int tree[Maxn];//可以用数组表示完全二叉树,根结点编号为1; 
int sequence[Maxn];
int n;
int index = 0;
void inorder(int root) {
	if(root > n)//编号大于结点个数,说明该结点是空结点; 
		return;
	inorder(2 * root);
	tree[root] = sequence[index++];
	inorder(2 * root + 1);
}

int main() {
	cin >> n;
	for(int i = 0; i < n; i++)
		cin >> sequence[i];
	sort(sequence, sequence + n);//得到一个二叉查找树的中序遍历序列;
	inorder(1);//按中序遍历对该完全二叉树进行填充
	for(int i = 1; i <=n; i++) {
		if(i != 1)
			cout << " ";
		cout << tree[i];//对完全二叉树从1到n输出就是其层序遍历; 	
	}
	
	return 0;
} 

知识点:

①完全二叉树的定义:完全二叉树是指完全填充的树,但底层可能除外,底层是从左到右填充的。

②完全二叉树的存储除了用二叉链表存储以外还可以用更方便的数组进行存储,从1开始(根节点下标,1号位存放的必须是根节点),到n,下标为其结点的编号,值为权重。

这样就有:完全二叉树中任意一个结点编号为x,则左节点一定是2x,右节点的编号一定是2x+1

除以以外,该数组中元素的存放顺序恰好是该完全二叉树的层序遍历序列。

③二叉查找树的中序遍历序列满足从小到大排序的规律,可以通过中序遍历序列找到各个权重的在树中结点的位置。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值