HDU - 1969 Pie

问题描述:

My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

输入说明:

One line with a positive integer: the number of test cases. Then for each test case:
—One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
—One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

输出说明:

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

SAMPLE INPUT:

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

SAMPLEOUTPUT:

25.1327
3.1416
50.2655

思路:

题意是要把N张饼,分给F个人,因为自己也要分到一份,所以数量要加一。输入的数据是半径,所以在输入的同时,去乘上π得到面积,注意这里的π需要通过反三角来求得,然后将所有的面积从大到小排序,以最大饼的面积作为终点,0作为起点开始二分,对于每一个面积都要进行考虑,判断其能否分给所有的朋友,注意要精确到1e-5

AC代码:

#include <bits/stdc++.h>
#define pi 4*atan(1.0)
using namespace std;
double a[100000];
int n,m,i;
int f(double middle)
{
    int sum=0;
    for(i=0;i<n;i++)
    {
        int temp=a[i]/middle;
        sum+=(int)temp;
        if(sum>=m)
            return 1;
    }
    return 0;
}
int main()
{
    int t,x,i,j;
    double l,r,middle;
    cin>>t;
    while(t--)
    {
        memset(a,0,sizeof(a));
        cin>>n>>m;
        m++;
        for(i=0;i<n;i++)
        {
            cin>>x;
            a[i]=x*x*pi;
        }
        sort(a,a+n,greater<int>());
        l=0.0;
        r=a[0]*1.0;
        n=min(n,m);
        while(r-l>1e-5)
        {
            middle=(r+l)/2;
            if(f(middle)==1)
                l=middle;
            else
                r=middle;
        }
        cout<<fixed<<setprecision(4)<<l<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
项目:使用AngularJs编写的简单 益智游戏(附源代码)  这是一个简单的 javascript 项目。这是一个拼图游戏,也包含一个填字游戏。这个游戏玩起来很棒。有两个不同的版本可以玩这个游戏。你也可以玩填字游戏。 关于游戏 这款游戏的玩法很简单。如上所述,它包含拼图和填字游戏。您可以通过移动图像来玩滑动拼图。您还可以选择要在滑动面板中拥有的列数和网格数。 另一个是填字游戏。在这里你只需要找到浏览器左侧提到的那些单词。 要运行此游戏,您需要在系统上安装浏览器。下载并在代码编辑器中打开此项目。然后有一个 index.html 文件可供您修改。在命令提示符中运行该文件,或者您可以直接运行索引文件。使用 Google Chrome 或 FireFox 可获得更好的用户体验。此外,这是一款多人游戏,双方玩家都是人类。 这个游戏包含很多 JavaScript 验证。这个游戏很有趣,如果你能用一点 CSS 修改它,那就更好了。 总的来说,这个项目使用了很多 javascript 和 javascript 库。如果你可以添加一些具有不同颜色选项的级别,那么你一定可以利用其库来提高你的 javascript 技能。 演示: 该项目为国外大神项目,可以作为毕业设计的项目,也可以作为大作业项目,不用担心代码重复,设计重复等,如果需要对项目进行修改,需要具备一定基础知识。 注意:如果装有360等杀毒软件,可能会出现误报的情况,源码本身并无病毒,使用源码时可以关闭360,或者添加信任。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值