HDU 1969 Pie(二分查找)

Pie

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4053    Accepted Submission(s): 1634


Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 

Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
 

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

Sample Input
  
  
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
 

Sample Output
  
  
25.1327 3.1416 50.2655
 


#include<iostream>

#include<cstdio>
#include<cmath>
#include<iomanip>
using namespace std;
const int maxn=10005;
const double pi=4.0*atan(1.0);/*这是真正准确的pi值,cmath函数中的常量M_PI并不是ANSI C标准的*/
const double eps=1e-6;
int a[maxn];//存储饼的半径
int t,n,m;//t个测试案例,n个pie,m个朋友
int main()
{
double bs(double,double);
cin>>t;
while(t--)
{
cin>>n>>m;
for(int i=0;i<n;i++)
{scanf("%d",&a[i]);}
double max=0;
for(i=0;i<n;i++)
{max+=a[i]*a[i];}
max/=m+1;/*这是所有的饼充分利用时每个人都能得到的面积,但是这显然不满足题中的条件
   我们要找的答案位于0~max之间*/
double s=bs(eps,max);/*这里的起点不能写为0,因为在f函数中会出现除零错误*/
s*=pi;
cout<<setiosflags(ios::fixed)<<setprecision(4)<<s<<endl;
/*题中说误差at most 10^(-3),表示一定要输出小数点后4位,4位以上wronganswer*/
}
return 0;
}


double bs(double begin,double end)
{
int f(double);
double mid;
while(fabs(begin-end)>1e-8)/*这里我们不用人数来控制循环而是用面积来控制循环,差值取1e-9时超时*/
{
mid=(begin+end)/2;
if(f(mid)>=m+1){begin=mid;}
else{end=mid;}
}
return mid;
}
int f(double s)/*用于计算当前面积设定为s时能供给的人数*/
{
int sum=0;/*sum是指在当前设定的每份饼的面积下,可以供给多少个人*/
/*如果多于m+1则表示饼的面积还可以提高,如果小于m+1则表明饼的面积要适当减小*/
for(int i=0;i<n;i++)
{sum+=floor(a[i]*a[i]/s);}/*如果不加floor就AnswerWrong*/
return sum;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值