HDU 1022 stack

题目链接

题意

火车入站
给定123 即火车按照123 入站
给定321 问火车是否能按321 出站
如果能给定入栈出栈方式

Sample Input
3 123 321
3 123 312
Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

思路

#include<bits/stdc++.h>
typedef long long ll;
using namespace std;
const int mod=1000000007,N=2e5+10;
int arr[N];
int main(){
	int n;
	string s1,s2;
	while(cin>>n>>s1>>s2)
	{
		stack<char> sta;
		int now=0;
		vector<string> ve;
		for(int i=0;i<n;i++)
		{
			sta.push(s1[i]);
			ve.push_back("in");
			while(sta.size()&&sta.top()==s2[now])//符合的时候,开始执行循环
			{
				sta.pop();
				ve.push_back("out");
				now++;
			}
		}
		if(sta.empty())//为空则为1 即代表栈中元素全部弹出
		{
			cout<<"Yes."<<endl;
			for(auto v:ve)
			{
				cout<<v<<endl;
			}
			cout<<"FINISH"<<endl;
		}
		else
		{
			cout<<"No.\nFINISH"<<endl;	
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值