Goldbach‘s Conjecture

Problem Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a
letter to Leonhard Euler in which he made the following conjecture:

Every even number greater than 4 can be written as the sum of two odd
prime numbers.

For example:

8 = 3 + 5. Both 3 and 5 are odd prime numbers. 20 = 3 + 17 = 7 + 13.
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait,
I have the proof of course, but it is too long to write it on the
margin of this page.) Anyway, your task is now to verify Goldbach’s
conjecture for all even numbers less than a million.

Input

The input will contain one or more test cases.
Each test case
consists of one even integer n with 6 <= n < 1000000.
Input will
be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and
b are odd primes. Numbers and operators should be separated by exactly
one blank like in the sample output below. If there is more than one
pair of odd primes adding up to n, choose the pair where the
difference b - a is maximized. If there is no such pair, print a line
saying “Goldbach’s conjecture is wrong.”

Sample Input

8 20 42 0

Sample Output

8 = 3 + 5 20 = 3 + 17 42 = 5 + 37

题目大意:题目意思很简单就是任何一个偶数都可以分成两个奇数的和,并且两个奇数的差要是最大

解题思路:打表,素数筛选出来。
代码:

#include<stdio.h>
#include<stdlib.h>
#define Max 1000005
int prime[Max];

void is_prime()
{
    long i;
    prime[0]=0;
    prime[1]=0;
    for(i=2;i<Max;i++)
        prime[i]=1;
    for(i=2;i<Max;i++){

        if(prime[i])
        {
            long j=i*2;
            while(j<Max)
            {
                prime[j]=0;//从2开始依次筛选其倍数
                j+=i;
            }
        }
    }
}

int main()
{
    long n,i;
    is_prime();
    while(~scanf("%Id",&n))
    {
        for(i=2;i<n;i++){
            if(prime[i]&&prime[n-i])
            {
                printf("%Id = %Id + %Id\n",n,i,n-i);
                break;
            }
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值