1058 Humble Numbers

34 篇文章 0 订阅

题目详情:

 ​

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36047    Accepted Submission(s): 15727

Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 
Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n. 
Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 
Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0
 
Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.
 
Source
 
Recommend
JGShining   |   We have carefully selected several similar problems for you:  1003 1159 1069 1087 1176 

 题目大意:

一个数它的因子只有2,3,5,7其中的一个或多个的任意组合的数叫丑数,现在请你写一个程序找出第N个丑数!

解题思路:

设h2=1,h3=1,h5=1,h7=1,状态转移方程:num[i]=min(min(2*num[h2],3*num[h3]),min(5*num[h5],7*num[h7])),同时用num[i]和之前的这四个数作比较,相等则使对应的h加一。

AC代码:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int main(){
    int n;
    vector<int> num(5846,0);
    num[1]=1;
    int h2=1,h3=1,h5=1,h7=1;
    for(int i=2;i<=5843;++i){
            num[i]=min(min(2*num[h2],3*num[h3]),min(5*num[h5],7*num[h7]));
            if(num[i]==2*num[h2]) h2++;
            if(num[i]==3*num[h3]) h3++;
            if(num[i]==5*num[h5]) h5++;
            if(num[i]==7*num[h7]) h7++;
    }
    while(cin>>n&&n){
        if(n%100==11||n%100==12||n%100==13) printf("The %dth humble number is %d.\n",n,num[n]); 
        else { 
            if(n%10==1) printf("The %dst humble number is %d.\n",n,num[n]); 
            else if(n%10==2)printf("The %dnd humble number is %d.\n",n,num[n]); 
            else if(n%10==3)printf("The %drd humble number is %d.\n",n,num[n]); 
            else printf("The %dth humble number is %d.\n",n,num[n]); 
        } 
    }   
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

无名之逆

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值