【1058】Humble Numbers

1058

Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

#include<bits/stdc++.h>
using namespace std;
int fn[6000];
int Min(int t1,int t2,int t3,int t4){
	int t;
	t=t1<t2?t1:t2;
	t=t<t3?t:t3;
	t=t<t4?t:t4;
	return t;
}
int main(){
	int n;
	fn[1]=1;
	int a1=1,a2=1,a3=1,a4=1;
	int e1,e2,e3,e4;
	for(int i=2;i<6000;i++){
		e1=fn[a1]*2;
		e2=fn[a2]*3;
		e3=fn[a3]*5;
		e4=fn[a4]*7;
		fn[i]=Min(e1,e2,e3,e4);
		if(fn[i]==e1)
			a1++;
		if(fn[i]==e2)
			a2++;
		if(fn[i]==e3)
			a3++;
		if(fn[i]==e4)
			a4++;
	}
	scanf("%d",&n);
	while(1){
		if(n==0)
			break;
		if(n%100==11||n%100==12||n%100==13){
			printf("The %dth humble number is %d.\n",n,fn[n]); 
		}else{
			int temp=n%10;
			if(temp==1){
				printf("The %dst humble number is %d.\n",n,fn[n]);
			}else if(temp==2){
				printf("The %dnd humble number is %d.\n",n,fn[n]);
			}else if(temp==3){
				printf("The %drd humble number is %d.\n",n,fn[n]);
			}else{
				printf("The %dth humble number is %d.\n",n,fn[n]);
			}
		}
		scanf("%d",&n);
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值