【高级数据结构】并查集

How Many Tables【HDU1213】

原题连接https://acm.hdu.edu.cn/showproblem.php?pid=1213

Problem Description

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

并查集模板题

Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output
2
4

#include<bits/stdc++.h>
using namespace std;
const int maxn=1050;
int s[maxn+1];
int height[maxn+1];//记录高度,可以用来优化合并————把矮的树合并到高的上,可以减少树的高度
inline void init_set(){
    for(int i=1;i<=maxn;++i){
        s[i]=i;
        height[i]=0;
    }
}
int find_set(int x){//递归实现
    if(x!=s[x])s[x]=find_set(s[x]);//路径压缩
    return s[x];
}

// int find_set(int x){//非递归写法,递归写法在数据规模很大情况下有爆栈的可能
//     int r=x;
//     while(s[r]!=r)r=s[r];//找到根节点
//     int i=x,j;
//     while(i!=r){
//         j=s[i];
//         s[i]=r;
//         i=j;
//     }
//     return r;
// }

void union_set(int x,int y){
    x=find_set(x);
    y=find_set(y);
    if(height[x]==height[y]){
        height[x]=height[x]+1;
        s[y]=x;
    } else {
        if(height[x]<height[y]) s[x]=y;
        else s[y]=x;
    }
}
int main(){
    int t,n,m,x,y;
    cin>>t;
    while(t--){
        cin>>n>>m;
        init_set();
        for(int i=0;i<m;++i){
            cin>>x>>y;
            union_set(x,y);
        }
        int ans=0;
        for(int i=1;i<=n;++i){
            if(s[i]==i)
                ans++;
        }
        cout<<ans<<endl;
    }
    system("pause");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

是君倩

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值