【PAT】【字符串处理 + 简单映射】1022 Digital Library (30 分)

 题目链接:1022 Digital Library (30 分)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

// 题目大意 或 类型: 字符串处理题以及简单映射

// 解题思路:
// 一个很简单的做法,可以发现,其实书的相关信息都是string,甚至id号也可以这么看
// 而且要求是给出其中一个信息进行查询相应包含的id号,那么简单的用一个string 到 set的映射就可以了

// 用set主要是为了可以按升序输出,然后按题目要求保存和查询就可以

// 这里的set<int> 是因为我觉得int 会比 string节省开销,但却造就我疏忽了下面这个问题

// !注意!:
// 上面说的也就是测试点3、4的坑点,id号首部可能有零,int型输出的话就忽略掉了造成wa
// 所以用int的话,要对输出格式进行控制,宽度7且不足补零

#include <iostream>
#include <cstdio>
#include <set>
#include <map>
#include <iomanip>
#include <sstream>
using namespace std;

map<string, set<int> > mp;
// 这里进行了字符串切割,有空的字符串切成单独的单词
void trans(string s, const int id)
{
    stringstream ss;
    string res = "";
    ss << s;
    while(ss >> res)
    {
        mp[res].insert(id);
    }
}
int main()
{
    // 读入数据
    int n; cin >> n;
    for(int id, i = 1; i <= n; i++)
    {
        string s; cin >> id; getchar();//getchar()是为了去掉行末换行符
        for(int j = 1; j <= 5; j++)
        {
            // 不去掉换行符这里会读入一行空行
            getline(cin, s);
            // keyword行进行字符串切割
            if(j == 3)
            trans(s, id);
            else
            mp[s].insert(id);
        }
    }
    int m; cin >> m;
    string c, s;
    for(int i = 1; i <= m; i++)
    {
        cin >> c; getchar();// 即"1: "这些
        getline(cin, s);
        // 原样输出一次
        cout << c << " " << s << endl;
        bool flag = true;
        for(auto it = mp[s].begin(); it != mp[s].end(); it++)
        {
            flag = false;
            // 格式控制
            cout << setfill('0') << setw(7) << *it << endl;
        }
        // 一个都没有则not found
        if(flag) cout << "Not Found" << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值