POJ 1896 Stones(优先队列)

Problem Description

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.

Output

Just output one line for one test case, as described in the Description.

Sample Input

2
2
1 5
2 4
2
1 5
6 6

Sample Output

11
12

思路

这题使用优先队列,优先队列可以将队列中的元素按照指定的方式排序。将石头都加入至队列中,队列按照距离从小到大排列,对于相同距离的则扔的距离近的排在前面。每次从队列中取出首元素,然后人移动到取出的石头所在的位置。定义一个变量,记录扔的次数,奇数再扔,并将扔的这块石头距离起点的距离更新为原距离加上扔的距离,偶数取出就不用管了。最后队列为空时,人所处位置即为答案

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<queue>
using namespace std;

struct stone
{
	int pi,di;
	friend bool operator<(stone a,stone b)
	{
		if(a.pi!=b.pi)
			return a.pi>b.pi;			//定义队列的排列顺序 
		return a.di>b.di;
	}
};

int n;
priority_queue<stone>q;					//定义优先队列 

int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		cin>>n;
		int a,b;
		stone c;
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&a,&b);
			c.pi=a;
			c.di=b;
			q.push(c);					//加入队列 
		}
		int cnt=0,dis=0;
		while(q.size())
		{
			cnt++;
			c=q.top();					//普通队列首元素首元素是front  优先队列是top 
			dis=c.pi;
			q.pop();
			if(cnt&1)					//奇数就扔出去 
			{
				c.pi=c.di+c.pi;
				q.push(c);				//扔完重新加入队列之中 
			}
		}
		cout<<dis<<endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值