Monthly Expense

农夫约翰面临财务问题,需要为接下来的N天制定M个连续的“fajomonths”预算。每个fajomonth包含连续的若干天,且所有天数都被覆盖。目标是最小化最高花费的fajomonth的支出,以确定月度支出上限。输入包含N天的花费详情,输出是可能的最小月度支出限制。
摘要由CSDN通过智能技术生成

Monthly Expense
Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers: N and M
Lines 2…N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400
Sample Output
500
Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.


题意:给出农夫在n天中每天的花费,要求把这n天分作m组,每组的天数必然是连续的,要求分得各组的花费之和应该尽可能地小,最后输出各组花费之和中的最大值。
左边界数组中的最大值,右边界数组的总和 ,二分答案。

#include <iostream>
#include <algorithm>

using namespace std ;

const int N = 1e5 + 100 ;
int n , m ;
int cost[N] ;
int sum = 0 ;
//要求分得各组的花费之和应该尽可能地小,
//最后输出各组花费之和中的最大值

bool check(int x)
{
    int num = 0 , ans = 1;
    for(int i = 1 ; i <= n ; i ++)
    {
        if(num + cost[i] > x)   //之和大于x , 组数增加 ;
            num = cost[i] , ans ++ ;  //num等于此时的cost[i] ;
        else
            num += cost[i] ;   
    }
    return ans > m ;
}

int main()
{
    cin >> n >> m ;
    int r  = 0 , l = 0 ;
    for(int i = 1 ; i <= n ; i ++)
        cin >> cost[i] , r += cost[i] , l = max(l , cost[i]) ;
    int mid = (l+r)/2 ;
    while(l < r)
    {
        if(check(mid))
            l = mid + 1;
        else
            r = mid - 1;
        mid = (l+r)/2 ;
    }
    cout << mid << endl ;
    return 0 ;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值