Monthly Expense
Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.
FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.
FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.
Input
Line 1: Two space-separated integers: N and M
Lines 2…N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400
Sample Output
500
Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.
题意:给出农夫在n天中每天的花费,要求把这n天分作m组,每组的天数必然是连续的,要求分得各组的花费之和应该尽可能地小,最后输出各组花费之和中的最大值。
左边界数组中的最大值,右边界数组的总和 ,二分答案。
#include <iostream>
#include <algorithm>
using namespace std ;
const int N = 1e5 + 100 ;
int n , m ;
int cost[N] ;
int sum = 0 ;
//要求分得各组的花费之和应该尽可能地小,
//最后输出各组花费之和中的最大值
bool check(int x)
{
int num = 0 , ans = 1;
for(int i = 1 ; i <= n ; i ++)
{
if(num + cost[i] > x) //之和大于x , 组数增加 ;
num = cost[i] , ans ++ ; //num等于此时的cost[i] ;
else
num += cost[i] ;
}
return ans > m ;
}
int main()
{
cin >> n >> m ;
int r = 0 , l = 0 ;
for(int i = 1 ; i <= n ; i ++)
cin >> cost[i] , r += cost[i] , l = max(l , cost[i]) ;
int mid = (l+r)/2 ;
while(l < r)
{
if(check(mid))
l = mid + 1;
else
r = mid - 1;
mid = (l+r)/2 ;
}
cout << mid << endl ;
return 0 ;
}