Monthly Expense

农夫约翰面临财务问题,需要为接下来的N天制定M个连续的“fajomonths”预算。每个fajomonth包含连续的若干天,且所有天数都被覆盖。目标是最小化最高花费的fajomonth的支出,以确定月度支出上限。输入包含N天的花费详情,输出是可能的最小月度支出限制。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Monthly Expense
Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers: N and M
Lines 2…N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400
Sample Output
500
Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.


题意:给出农夫在n天中每天的花费,要求把这n天分作m组,每组的天数必然是连续的,要求分得各组的花费之和应该尽可能地小,最后输出各组花费之和中的最大值。
左边界数组中的最大值,右边界数组的总和 ,二分答案。

#include <iostream>
#include <algorithm>

using namespace std ;

const int N = 1e5 + 100 ;
int n , m ;
int cost[N] ;
int sum = 0 ;
//要求分得各组的花费之和应该尽可能地小,
//最后输出各组花费之和中的最大值

bool check(int x)
{
    int num = 0 , ans = 1;
    for(int i = 1 ; i <= n ; i ++)
    {
        if(num + cost[i] > x)   //之和大于x , 组数增加 ;
            num = cost[i] , ans ++ ;  //num等于此时的cost[i] ;
        else
            num += cost[i] ;   
    }
    return ans > m ;
}

int main()
{
    cin >> n >> m ;
    int r  = 0 , l = 0 ;
    for(int i = 1 ; i <= n ; i ++)
        cin >> cost[i] , r += cost[i] , l = max(l , cost[i]) ;
    int mid = (l+r)/2 ;
    while(l < r)
    {
        if(check(mid))
            l = mid + 1;
        else
            r = mid - 1;
        mid = (l+r)/2 ;
    }
    cout << mid << endl ;
    return 0 ;
}
内容概要:本文详细探讨了基于樽海鞘算法(SSA)优化的极限学习机(ELM)在回归预测任务中的应用,并与传统的BP神经网络、广义回归神经网络(GRNN)以及未优化的ELM进行了性能对比。首先介绍了ELM的基本原理,即通过随机生成输入层与隐藏层之间的连接权重及阈值,仅需计算输出权重即可快速完成训练。接着阐述了SSA的工作机制,利用樽海鞘群体觅食行为优化ELM的输入权重和隐藏层阈值,从而提高模型性能。随后分别给出了BP、GRNN、ELM和SSA-ELM的具体实现代码,并通过波士顿房价数据集和其他工业数据集验证了各模型的表现。结果显示,SSA-ELM在预测精度方面显著优于其他三种方法,尽管其训练时间较长,但在实际应用中仍具有明显优势。 适合人群:对机器学习尤其是回归预测感兴趣的科研人员和技术开发者,特别是那些希望深入了解ELM及其优化方法的人。 使用场景及目标:适用于需要高效、高精度回归预测的应用场景,如金融建模、工业数据分析等。主要目标是提供一种更为有效的回归预测解决方案,尤其是在处理大规模数据集时能够保持较高的预测精度。 其他说明:文中提供了详细的代码示例和性能对比图表,帮助读者更好地理解和复现实验结果。同时提醒使用者注意SSA参数的选择对模型性能的影响,建议进行参数敏感性分析以获得最佳效果。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值