POJ - 1014 Dividing(深搜+剪枝)

我是传送门
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
Input
Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line “1 0 1 2 0 0”. The maximum total number of marbles will be 20000.
The last line of the input file will be “0 0 0 0 0 0”; do not process this line.
Output
For each collection, output “Collection #k:”, where k is the number of the test case, and then either “Can be divided.” or “Can’t be divided.”.
Output a blank line after each test case.
Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0
Sample Output
Collection #1:
Can’t be divided.

Collection #2:
Can be divided.


  • 题意:给出价值分别为1—6的玻璃球数量,求是否可以在不用切割的情况下分出等价值的两堆。
  • 分析:深搜不断测试,并且记录需要的价值,当前的价值,当前的玻璃球价值,必须从价值最高的6开始,如果从1开始,没法判断当前的玻璃球要不要,从大的开始,要与不要更容易判断;
  • ac代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
typedef long long ll;
using namespace std;
int flag=0;
int a[7];
int dfs(int mid,int ans,int st)//总价值的一半,当前搜集的价值,第几种玻璃球 
{
	int i;
	if(ans==mid)
	{
		flag=1;
		return flag;
	}
	for(i=st;i>=1;i--)
	{
		if(a[i])//当前价值的没有,直接遍历到更便宜的那个 
		{
			if(ans+i<=mid)
			{
				a[i]--;
				dfs(mid,ans+i,i);
				if(flag)
				break;
			}
		}
	}
	return flag;
}
int main()
{
	int g=1,sum,i;
	while(~scanf("%d%d%d%d%d%d",&a[1],&a[2],&a[3],&a[4],&a[5],&a[6]))
	{
		sum=0;
		flag=0;
		for(i=1;i<=6;i++)
			sum+=a[i]*i;
		if(sum==0)
		return 0;
		if(sum%2)//如果是奇数,一定没法平分 
		{
			printf("Collection #%d:\nCan't be divided.\n\n",g++);
			continue;
		}
		else
		{
		dfs(sum/2,0,6);//必须从最高遍历, 
		if(flag)
		printf("Collection #%d:\nCan be divided.\n\n",g++);
		else
		printf("Collection #%d:\nCan't be divided.\n\n",g++);
		}
	}
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值