算法入门 23. 4 Values whose Sum is 0(折半枚举)

168 篇文章 1 订阅
99 篇文章 1 订阅

4 Values whose Sum is 0

Time Limit: 15000MSMemory Limit: 228000K
Total Submissions: 41862Accepted: 12782
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n . 

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D . 

Output

For each input file, your program has to write the number quadruplets whose sum is zero. 

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30). 

Source

Southwestern Europe 2005

#include<iostream>
using namespace std;
int n;
int a[4001];
int b[4001];
int c[4001];
int d[4001];
const int maxn=10010;
int cd[maxn];
void init(){
    cin>>n;
    for(int i=0;i<n;i++) cin>>a[i];
    for(int i=0;i<n;i++) cin>>b[i];
    for(int i=0;i<n;i++) cin>>c[i];
    for(int i=0;i<n;i++) cin>>d[i];
}
void solve(){
    for(int i=0;i<n;i++){
        for(int j=0;j<n;j++){
            cd[i*n+j]=c[i]+d[j];
        }
    }
    sort(cd,cd+n*n);
    int res=0;
    for(int i=0;i<n;i++){
        for(int j=0;j<n;j++){
            int ab=-(a[i]+b[i]);
            res+=upper_bound(cd, cd+n*n,ab)-lower_bound(cd, cd+n*n, ab);
        }
    }
    cout<<res;
}
int main(){
    init();
    solve();
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

郭晋龙

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值