The Average (大根堆模板)

In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.

Let’s consider a generalized form of the problem above. Given n positive integers, remove the greatest n1 ones and the least n2 ones, and compute the average of the rest.

Input

The input consists of several test cases. Each test case consists two lines. The first line contains three integers n1, n2 and n (1 ≤ n1, n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains n positive integers ai (1 ≤ ai ≤ 108 for all i s.t. 1 ≤ i ≤ n) separated by a single space. The last test case is followed by three zeroes.

Output

For each test case, output the average rounded to six digits after decimal point in a separate line.

Sample Input

1 2 5
1 2 3 4 5
4 2 10
2121187 902 485 531 843 582 652 926 220 155
0 0 0

Sample Output

3.500000
562.500000

Hint

This problem has very large input data. scanf and printf are recommended for C++ I/O.

The memory limit might not allow you to store everything in the memory.

题目大概意思就是删掉n1个最大值和n2个最小值后的平均数。

解题分析;列一个大根堆出来,然后堆里面除了n1个最大数都清掉;n2同理;然后把2个堆分别加起来再用总和减掉他们的长度。

听懂了记得给个赞鼓励一下,码字不易,用爱发电。

上ac代码。

 我的头像

 有事你就q我;QQ2917366383

学习算法

#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
typedef long long ll;
ll n1,n2,n,sum;
priority_queue<ll> qmax,qmin;//大根堆 
 
int main(){
    while(scanf("%lld%lld%lld",&n1,&n2,&n)){//最大的有几个,最小的有几个,和有几位数 
        sum=0;
        if(n1+n2+n==0) break;//刚刚好删完 
        ll x;
        for(int i=1;i<=n;i++){
            scanf("%lld",&x); 
            sum+=x;//总和 
            qmax.push(-x);//为了由小到大 
            if(qmax.size()>n1 )
			qmax.pop();//删掉最前面n-n1个 
            qmin.push(x);//正规由大到小 
            if(qmin.size()>n2)//删掉前面n-n2个 
			qmin.pop();
        }
       {
    for(int i=1;i<=n1;i++){//最大数有几个删几个 
        sum+=qmax.top();//取第一个,删掉最大的和 
        qmax.pop();//不用了,删掉 
    }
    for(int i=1;i<=n2;i++){
        sum-=qmin.top();
        qmin.pop();
    }
    printf("%.6f\n",(sum*1.0)/(n-n1-n2));
}
    }
    return 0;
}

  • 4
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

算法编程张老师

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值