【暑期每日一题】洛谷 P2955 [USACO09OCT]Even? Odd? G

题目链接:P2955 [USACO09OCT]Even? Odd? G - 洛谷 | 计算机科学教育新生态 (luogu.com.cn)

题目描述

Bessie's cruel second grade teacher has assigned a list of N (1 <= N <= 100) positive integers I (1 <= I <= 10^60) for which Bessie must determine their parity (explained in second grade as 'Even... or odd?'). Bessie is overwhelmed by the size of the list and by the size of the numbers. After all, she only learned to count recently.

Write a program to read in the N integers and print 'even' on a single line for even numbers and likewise 'odd' for odd numbers.

POINTS: 25

Bessie那惨无人道的二年级老师搞了一个有 N 个正整数 I 的表叫Bessie去判断“奇偶性”(这个词语意思向二年级的学生解释,就是“这个数是单数,还是双数啊?”)。Bessie被那个表的长度深深地震惊到了,竟然跟栋栋的泛做表格一样多道题!!!毕竟她才刚刚学会数数啊。

写一个程序读入N个整数,如果是双数,那么在单立的一行内输出"even",如果是单数则类似地输出"odd".

输入格式

Line 1: A single integer: N

Lines 2..N+1: Line j+1 contains I_j, the j-th integer to determine even/odd

输出格式

Lines 1..N: Line j contains the word 'even' or 'odd', depending on the parity of I_j

样例 #1

样例输入 #1

2 
1024 
5931

样例输出 #1

even 
odd

提示

Two integers: 1024 and 5931
1024 is eminently divisible by 2; 5931 is not

AC code:(注意要用字符串!!!)

#include<iostream>

using namespace std;

int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		string x;
		cin>>x;
		if((x[x.size()-1]-'0')%2)
			cout<<"odd\n";
		else
			cout<<"even\n";
	}
	
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值