【c++刷题Day1】专题1T3

这是c++刷题的Day1
在这里插入图片描述💯题目描述

给出硬币面额及每种硬币的个数,求从1到m能凑出面额的个数。

Input
多组数据,每组数据前两个数字为n,m。n表示硬币种类数,m为最大面额,之后前n个数为每种硬币的面额,后n个数为相应每种硬币的个数。 (n<=100,m<=100000,面额<=100000,每种个数<=1000)
Output
RT
Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

🔑思路

bitset+dp

💯CODE代码:

#include <bits/stdc++.h>
using namespace std ;
bitset < 100010 > f ;
int n , m ;
struct Node {
	int a , b ;
} cs[110] ;
void T (int a , int b) {
	if (a > m)
		return ;
	int res = 1 ;
	while (b >= res) {
		f |= f << (res * a) ;
		b -= res ;
		res <<= 1 ;
		if (res * a > m)
			return ;
	}
	if (b)
		dp |= dp << (a * b) ;
}
int main () {
	while (cin >> n >> m && n) {
		for (int i = 0; i < n; i ++)
			cin >> cs[i].a ;
		for (int i = 0; i < n; i ++)
			cin >> cs[i].b ;
		
		f.reset () ;
		f.set (0) ;
		for (int i = 0; i < n; i ++)
			T (cs[i].a , cs[i].b) ;
		int res = 0 ;
		for (int i = 1; i <= m; i ++)
			res += f.test (i) ;
		cout << res << endl ;
	}
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

{∞}

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值