每日实验---MGRE环境下的OSPF

题目

配置

  1. 给所有接口配置IP和环回地址
    R1
    [r1]interface GigabitEthernet 0/0/0
    [r1-GigabitEthernet0/0/0]ip address 16.1.1.1 24 
    [r1]interface GigabitEthernet 0/0/1
    [r1-GigabitEthernet0/0/1]ip address 16.2.2.1 24
    [r1]interface LoopBack 0
    [r1-LoopBack0]ip address 1.1.1.1 24
    
    R2
    [r2]interface GigabitEthernet 0/0/0
    [r2-GigabitEthernet0/0/0]ip address 26.1.1.1 24
    [r2]interface LoopBack 0
    [r2-LoopBack0]ip address 2.2.2.2 24
    R3
    [r3]interface GigabitEthernet 0/0/0
    [r3-GigabitEthernet0/0/0]ip address 36.1.1.1 24
    [r3]interface LoopBack 0
    [r3-LoopBack0]ip address 3.3.3.3 24
    R4
    [r4]interface GigabitEthernet 0/0/0
    [r4-GigabitEthernet0/0/0]ip address 46.1.1.1 24
    [r4]interface LoopBack 0
    [r4-LoopBack0]ip address 4.4.4.4 24
    R5
    [r5]interface GigabitEthernet 0/0/0
    [r5-GigabitEthernet0/0/0]ip address 56.1.1.1 24
    [r5]interface LoopBack 0
    [r5-LoopBack0]ip address 5.5.5.5 24
    R6
    [r6]interface GigabitEthernet 0/0/0 
    [r6-GigabitEthernet0/0/0]ip address 16.1.1.2 24
    [r6]interface GigabitEthernet 0/0/1
    [r6-GigabitEthernet0/0/1]ip address 16.2.2.2 24
    [r6]interface GigabitEthernet 0/0/2
    [r6-GigabitEthernet0/0/2]ip address 26.1.1.2 24
    [r6]interface GigabitEthernet 1/0/0
    [r6-GigabitEthernet1/0/0]ip address 36.1.1.2 24
    [r6]interface GigabitEthernet 2/0/0
    [r6-GigabitEthernet2/0/0]ip address 46.1.1.2 24
    [r6]interface GigabitEthernet 3/0/0
    [r6-GigabitEthernet3/0/0]ip address 56.1.1.2 24
  2. 补全公网路由
    R1
    [r1]ip route-static 0.0.0.0 0 16.1.1.2
    [r1]ip route-static 0.0.0.0 0 16.2.2.2
    R2
    [r2]ip route-static 0.0.0.0 0 26.1.1.2
    R3
    [r3]ip route-static 0.0.0.0 0 36.1.1.2
    R4
    [r4]ip route-static 0.0.0.0 0 46.1.1.2
    R5
    [r5]ip route-static 0.0.0.0 0 56.1.1.2
  3. 配置全连的MGRE结构
    R1
    [r1]interface Tunnel 0/0/0
    [r1-Tunnel0/0/0]ip address 145.1.1.1 24
    [r1-Tunnel0/0/0]tunnel-protocol gre p2mp 
    [r1-Tunnel0/0/0]source 16.1.1.1
    [r1-Tunnel0/0/0]ospf network-type broadcast
    [r1-Tunnel0/0/0]nhrp entry multicast dynamic
    [r1-Tunnel0/0/0]nhrp entry 145.1.1.4 46.1.1.1 register
    [r1-Tunnel0/0/0]nhrp entry 145.1.1.5 56.1.1.1 register
    R4
    [r4]interface Tunnel 0/0/0
    [r4-Tunnel0/0/0]ip address 145.1.1.4 24
    [r4-Tunnel0/0/0]tunnel-protocol gre p2mp 
    [r4-Tunnel0/0/0]source 46.1.1.1
    [r4-Tunnel0/0/0]ospf network-type broadcast
    [r4-Tunnel0/0/0]nhrp entry multicast dynamic
    [r4-Tunnel0/0/0]nhrp entry 145.1.1.1 16.1.1.1 register
    [r4-Tunnel0/0/0]nhrp entry 145.1.1.5 56.1.1.1 register
    R5
    [r5]interface Tunnel 0/0/0
    [r5-Tunnel0/0/0]ip address 145.1.1.5 24
    [r5-Tunnel0/0/0]tunnel-protocol gre p2mp 
    [r5-Tunnel0/0/0]source 56.1.1.1
    [r5-Tunnel0/0/0]ospf network-type broadcast
    [r5-Tunnel0/0/0]nhrp entry multicast dynamic
    [r5-Tunnel0/0/0]nhrp entry 145.1.1.1 16.1.1.1 register
    [r5-Tunnel0/0/0]nhrp entry 145.1.1.4 46.1.1.1 register
  4. 配置星型拓扑
    R1
    [r1]interface Tunnel 0/0/1
    [r1-Tunnel0/0/1]ip address 123.1.1.1 24
    [r1-Tunnel0/0/1]tunnel-protocol gre p2mp 
    [r1-Tunnel0/0/1]source 16.2.2.1
    [r1-Tunnel0/0/1]ospf network-type broadcast
    [r1-Tunnel0/0/1]nhrp entry multicast dynamic
    R2
    [r2]interface Tunnel 0/0/1
    [r2-Tunnel0/0/1]ip address 123.1.1.2 24
    [r2-Tunnel0/0/1]tunnel-protocol gre p2mp 
    [r2-Tunnel0/0/1]source GigabitEthernet 0/0/0
    [r2-Tunnel0/0/1]nhrp entry 123.1.1.1 16.2.2.1 register
    [r2-Tunnel0/0/1]ospf network-type broadcast
    [r2-Tunnel0/0/1]ospf dr-priority 0
     R3
    [r3]interface Tunnel 0/0/1
    [r3-Tunnel0/0/1]ip address 123.1.1.3 24
    [r3-Tunnel0/0/1]tunnel-protocol gre p2mp 
    [r3-Tunnel0/0/1]source GigabitEthernet 0/0/0
    [r3-Tunnel0/0/1]nhrp entry 123.1.1.1 16.2.2.1 register
    [r3-Tunnel0/0/1]ospf network-type broadcast
    [r3-Tunnel0/0/1]ospf dr-priority 0
  5. 配置OSPF
    R1
    [r1]ospf 1 router-id 1.1.1.1 
    [r1-ospf-1]area 0.0.0.0 
    [r1-ospf-1-area-0.0.0.0]network 1.1.1.1 0.0.0.0 
    [r1-ospf-1-area-0.0.0.0]network 123.1.1.1 0.0.0.0 
    [r1-ospf-1-area-0.0.0.0]network 145.1.1.1 0.0.0.0 
    R2
    [r2]ospf 1 router-id 2.2.2.2 
    [r2-ospf-1]area 0.0.0.0 
    [r2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0 
    [r2-ospf-1-area-0.0.0.0]network 123.1.1.2 0.0.0.0 
    R3
    [r3]ospf 1 router-id 3.3.3.3 
    [r3-ospf-1]area 0.0.0.0 
    [r3-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0 
    [r3-ospf-1-area-0.0.0.0]network 123.1.1.3 0.0.0.0 
    R4
    [r4]ospf 1 router-id 4.4.4.4 
    [r4-ospf-1]area 0.0.0.0 
    [r4-ospf-1-area-0.0.0.0]network 4.4.4.4 0.0.0.0 
    [r4-ospf-1-area-0.0.0.0]network 145.1.1.4 0.0.0.0 
    R5
    [r5]ospf 1 router-id 5.5.5.5 
    [r5-ospf-1]area 0.0.0.0 
    [r5-ospf-1-area-0.0.0.0]network 5.5.5.5 0.0.0.0 
    [r5-ospf-1-area-0.0.0.0]network 145.1.1.5 0.0.0.0 
    
  6. 测试
    R1
    <r1>ping -a 1.1.1.1 2.2.2.2
      PING 2.2.2.2: 56  data bytes, press CTRL_C to break
        Reply from 2.2.2.2: bytes=56 Sequence=1 ttl=255 time=30 ms
        Reply from 2.2.2.2: bytes=56 Sequence=2 ttl=255 time=30 ms
        Reply from 2.2.2.2: bytes=56 Sequence=3 ttl=255 time=20 ms
        Reply from 2.2.2.2: bytes=56 Sequence=4 ttl=255 time=30 ms
        Reply from 2.2.2.2: bytes=56 Sequence=5 ttl=255 time=50 ms
    
      --- 2.2.2.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 20/32/50 ms
    
    <r1>ping -a 1.1.1.1 4.4.4.4
      PING 4.4.4.4: 56  data bytes, press CTRL_C to break
        Reply from 4.4.4.4: bytes=56 Sequence=1 ttl=255 time=40 ms
        Reply from 4.4.4.4: bytes=56 Sequence=2 ttl=255 time=20 ms
        Reply from 4.4.4.4: bytes=56 Sequence=3 ttl=255 time=30 ms
        Reply from 4.4.4.4: bytes=56 Sequence=4 ttl=255 time=30 ms
        Reply from 4.4.4.4: bytes=56 Sequence=5 ttl=255 time=20 ms
    
      --- 4.4.4.4 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 20/28/40 ms
    R2
    <r2>ping -a 2.2.2.2 4.4.4.4
      PING 4.4.4.4: 56  data bytes, press CTRL_C to break
        Reply from 4.4.4.4: bytes=56 Sequence=1 ttl=254 time=40 ms
        Reply from 4.4.4.4: bytes=56 Sequence=2 ttl=254 time=40 ms
        Reply from 4.4.4.4: bytes=56 Sequence=3 ttl=254 time=50 ms
        Reply from 4.4.4.4: bytes=56 Sequence=4 ttl=254 time=40 ms
        Reply from 4.4.4.4: bytes=56 Sequence=5 ttl=254 time=30 ms
    
      --- 4.4.4.4 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 30/40/50 ms
    

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值