中国大学MOOC-陈越、何钦铭-数据结构-起步能力自测题自测-5 Shuffling Machine (20 分)

自测-5 Shuffling Machine (20 分)

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

结尾无空行

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

结尾无空行

这个题目的意思是:假设一个已经按照S1-13 H1-13 C1-13 D1-13 J1-2 顺序放好的牌要求你按照特点的顺序重新摆放,比如题目中的S3, H5, C1, D13  J2 要求{4, 2, 5, 3, 1}摆放,即第四个要求是S3(原第一个),第二个要求是H5(原第二个),第五个要求是C1(原第三个),第三个要求是D13(原第四个),第一个要求是S3(原第五个)。因此后来题目的给出顺序为整副牌54张的。

话不多说直接上代码,这道题最坑的点是末尾不能有空格,当然我偷懒了牺牲了代码的长度。

 


#include<stdio.h>
int a[56];
int b[30][56];
int main(){
	int i,j,n;
	for(i=1;i<=54;i++) b[0][i]=i;
	scanf("%d",&n);
	for(i=1;i<=54;i++) scanf("%d",&a[i]);
	for(i=1;i<=n;i++)
	for(j=1;j<=54;j++)
	b[i][a[j]]=b[i-1][j]; //关键 是让按照a[j]重新摆放b,当然i++直到n次这样比较方便
	for(i=1;i<54;i++){
		if(b[n][i]>=1&&b[n][i]<=13) printf("S%d ",b[n][i]);
		else if(b[n][i]>=14&&b[n][i]<=26) printf("H%d ",b[n][i]-13);
		else if(b[n][i]>=27&&b[n][i]<=39) printf("C%d ",b[n][i]-26);
		else if(b[n][i]>=40&&b[n][i]<=52) printf("D%d ",b[n][i]-39);
		else if(b[n][i]>=53) printf("J%d ",b[n][i]-52);
	}
	if(b[n][i]>=1&&b[n][i]<=13) printf("S%d",b[n][i]);
		else if(b[n][i]>=14&&b[n][i]<=26) printf("H%d",b[n][i]-13);
		else if(b[n][i]>=27&&b[n][i]<=39) printf("C%d",b[n][i]-26);
		else if(b[n][i]>=40&&b[n][i]<=52) printf("D%d",b[n][i]-39);
		else if(b[n][i]>=53) printf("J%d",b[n][i]-52);
	
	return 0;
} 

​

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值