[PTA MOOC] 自测-5 Shuffling Machine(20 分)

自测-5 Shuffling Machine(20 分)

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13,
H1, H2, ..., H13,
C1, C2, ..., C13,
D1, D2, ..., D13,
J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27
6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31
32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3
S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1
S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5


#include <iostream>
#include <cstring>
using namespace std;

int deck[54];
int order[54];
int res[54];

void pass(int a[], int b[]) {
    for(int i=0; i<54; ++i) {
        deck[i] = res[i];
    }
}
/*-----------------------------------------------
*这里可以用c++11里面的array容器更简洁地实现           
*因为array可以直接赋值                             
*也就是直接array<int, 54> deck与array<int, 54> res 
*deck = res;
*-----------------------------------------------
*/
void shuffle(int a[], int b[]) {
    //int tmp=0;
    memset(res,0,sizeof(int)*54);
    for(int i=0; i<54; ++i) {
        res[b[i]-1] = a[i];
    }
    //这里很重要,因为需要多次洗牌,所以deck要更新,不然不好操作
    pass(deck, res);
}

void print(int deck[]) {
    for(int i=0; i<54; ++i) {
    //-1+1的操作有点闹心,细心一点
        switch((deck[i]-1)/13) {
            case 0:
                cout<<'S'<<(deck[i]-1)%13+1;
                break;
            case 1:
                cout<<'H'<<(deck[i]-1)%13+1;
                break;
            case 2:
                cout<<'C'<<(deck[i]-1)%13+1;
                break;
            case 3:
                cout<<'D'<<(deck[i]-1)%13+1;
                break;
            case 4:
                cout<<'J'<<(deck[i]-1)%13+1;
        }
        //格式问题
        if(i!=53) cout<<' ';
    }
}

int main() {
    for(int i=0; i<54; ++i) {
        deck[i] = i+1;
    }
    int n;
    cin >> n;
    for(int i=0; i<54; ++i) {
        cin >> order[i];
    }
    while(n) {
        shuffle(deck, order);
        --n;
    }
    print(deck);
    return 0;
}
  • break; 不要忘记
下面是一个简单的二查找的完整代码实现,该代码实现了在有序数组中查找指定元素的功能。 ```c++ #include <iostream> using namespace std; int binarySearch(int arr[], int left, int right, int x) { while (left <= right) { int mid = left + (right - left) / 2; // 如果 x 在中间 if (arr[mid] == x) return mid; // 如果 x 大于中间元素,只需要在右半部搜索 if (arr[mid] < x) left = mid + 1; // 如果 x 小于中间元素,只需要在左半部搜索 else right = mid - 1; } // 如果 x 没有在数组中找到,返回 -1 return -1; } int main() { int arr[] = { 2, 3, 4, 10, 40 }; int n = sizeof(arr) / sizeof(arr[0]); int x = 10; int result = binarySearch(arr, 0, n - 1, x); if (result == -1) cout << "元素不在数组中!"; else cout << "元素在数组中的索引为:" << result; return 0; } ``` 在上面的代码中,`binarySearch` 函数是实现二查找的主要函数。该函数接受四个参数:要搜索的数组 `arr`,搜索范围的左边界 `left`,搜索范围的右边界 `right`,以及要查找的元素 `x`。 函数使用一个 while 循环来查找元素,只要搜索范围还没有缩小到只包含一个元素,就继续执行循环。在每次循环中,函数会计算搜索范围的中间位置 `mid`。然后,函数会检查中间位置的元素是否等于要查找的元素。如果是,函数会返回中间位置的索引。 如果中间位置的元素小于要查找的元素,那么要查找的元素只可能出现在中间位置的右侧。因此,函数会将搜索范围的左边界移到中间位置的右边一位。如果中间位置的元素大于要查找的元素,那么要查找的元素只可能出现在中间位置的左侧。因此,函数会将搜索范围的右边界移到中间位置的左边一位。 如果在循环结束时还没有找到要查找的元素,函数会返回 -1,表示元素不在数组中。否则,函数会返回要查找的元素在数组中的索引。
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值