NOI.7.18:验证子串

 描述

输入两个字符串,验证其中一个串是否为另一个串的子串。

输入

输入两个字符串, 每个字符串占一行,长度不超过200且不含空格。

输出

若第一个串s1是第二个串s2的子串,则输出(s1) is substring of (s2)
否则,若第二个串s2是第一个串s1的子串,输出(s2) is substring of (s1)
否则,输出 No substring。

样例输入

abc
dddncabca

样例输出

abc is substring of dddncabca

要注意:

1.strstr()函数的使用

 描述

C 库函数 char *strstr(const char *haystack, const char *needle) 在字符串 haystack 中查找第一次出现字符串 needle 的位置,不包含终止符 '\0'。

  声明

下面是 strstr() 函数的声明。

char *strstr(const char *haystack, const char *needle)                                  

  返回值
该函数返回在 haystack 中第一次出现 needle 字符串的位置,如果未找到则返回 null。

2.当两个字符串完全相同的时候,确保只输出一次 

#include<stdio.h>
#include<string.h>
#define N 210
int main()
{
    char s1[N]=" ",s2[N]=" ";
    scanf("%s",s1+1);
    scanf("%s",s2+1);
    char *flag1=strstr(s2+1,s1+1);
    if(flag1!=0)
    {
      printf("%s is substring of %s",s1+1,s2+1);
    }
    char *flag2=strstr(s1+1,s2+1);
    if(flag2!=0&&strcmp(s1,s2))
    {
      printf("%s is substring of %s",s2+1,s1+1);
    } 
    else if (flag1==0&&flag2==0)
    {
      printf("No substring");
    }
    return 0;
}

  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值