描述
输入两个字符串,验证其中一个串是否为另一个串的子串。
输入
输入两个字符串, 每个字符串占一行,长度不超过200且不含空格。
输出
若第一个串s1是第二个串s2的子串,则输出(s1) is substring of (s2)
否则,若第二个串s2是第一个串s1的子串,输出(s2) is substring of (s1)
否则,输出 No substring。
样例输入
abc dddncabca
样例输出
abc is substring of dddncabca
要注意:
1.strstr()函数的使用
描述
C 库函数 char *strstr(const char *haystack, const char *needle) 在字符串 haystack 中查找第一次出现字符串 needle 的位置,不包含终止符 '\0'。
声明
下面是 strstr() 函数的声明。
char *strstr(const char *haystack, const char *needle)
返回值
该函数返回在 haystack 中第一次出现 needle 字符串的位置,如果未找到则返回 null。
2.当两个字符串完全相同的时候,确保只输出一次
#include<stdio.h>
#include<string.h>
#define N 210
int main()
{
char s1[N]=" ",s2[N]=" ";
scanf("%s",s1+1);
scanf("%s",s2+1);
char *flag1=strstr(s2+1,s1+1);
if(flag1!=0)
{
printf("%s is substring of %s",s1+1,s2+1);
}
char *flag2=strstr(s1+1,s2+1);
if(flag2!=0&&strcmp(s1,s2))
{
printf("%s is substring of %s",s2+1,s1+1);
}
else if (flag1==0&&flag2==0)
{
printf("No substring");
}
return 0;
}