【题目描述】
输入两个字符串,验证其中一个串是否为另一个串的子串。
【输入】
输入两个字符串, 每个字符串占一行,长度不超过200且不含空格。
【输出】
若第一个串s1是第二个串s2的子串,则输出(s1) is substring of (s2)
否则,若第二个串s2是第一个串s1的子串,输出(s2) is substring of (s1)
否则,输出 No substring。
【输入样例】
abc
dddncabca【输出样例】
abc is substring of dddncabca
【源程序】
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
char s1[200],s2[200];
gets(s1);//获取字符串s1
gets(s2);//获取字符串s2
if(strstr(s2,s1))//判断s1是否是s2的子串
{
cout<<s1<<" is substring of "<<s2<<endl;
return 0;
}
if(strstr(s1,s2))//判断s2是否是s1的子串
{
cout<<s2<<" is substring of "<<s1<<endl;
return 0;
}
cout<<"No substring"<<endl;
return 0;
}