1027 Colors in Mars (20 分)-PAT甲级

People in Mars represent(展示) the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix(基数) 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased(大写的). If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

 思路:1.运用进制转换算法,将10进制数转换成13进制数

             2.注意某个颜色转换后为一个数字的话,要补前导0

              3.c++string对“+”进行了重载,s+=‘a’,s+="a",s.insert(s.end(),1,'a'),s.insert(s.end(),"a")效果相同

AC代码

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
int main()
{
	int a[3];
	string s="#",temp;
	for(int i=0;i<3;i++)
		cin>>a[i];
	for(int i=0;i<3;i++)
	{
		temp.clear();
		if(a[i]==0)
			temp="00";
		while(a[i]>0)
		{
			if(a[i]%13>=10)
				temp.insert(temp.end(),1,'A'+a[i]%13-10);
			else
				temp+=to_string(a[i]%13);
			a[i]/=13;
		}
		if(temp.size()==1)
			temp.insert(0,1,'0'); 
		else
			reverse(temp.begin(),temp.end());
		s+=temp;
	}
	cout<<s;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值