1031 Hello World for U (20 分)-PAT甲级

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical(竖直的) line with n1​ characters, then left to right along the bottom line with n2​ characters, and finally bottom-up along the vertical line with n3​ characters. And more, we would like U to be as squared(平方的) as possible -- that is, it must be satisfied that n1​=n3​=max { k | k≤n2​ for all 3≤n2​≤N } with n1​+n2​+n3​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified(明确规定的) in the description(描述).

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

 思路:1.关键在于读懂题目n1,n2,n3取值的描述,要求U尽可能方正,即n1,n2,n3最为接近,即n1=n2=(n1+n2+n3)/3(向下取整),n3=(n1+n2+n3)/3(向上取整)。

            2.打印平面图形,大部分都要用到二维数组,vector容器定义二维数组的方式为vector<vector<数据类型> >(行数,vector<列数,初值>)

 AC代码

#include <iostream>
#include <vector>
#include <string>
using namespace std;
int main()
{
	int n1,n2,n,k=0;
	string s;
	cin>>s;
	n=s.length();
	n1=(n+2)/3;
	n2=n+2-n1*2;
	vector<vector<char> >a(n1,vector<char>(n2));
	for(int i=0;i<n1;i++)
		for(int j=0;j<n2;j++)
		{
			if(i!=n1-1)
			{
				if(j==0)
					a[i][j]=s[k];
				else if(j==n2-1)
				{
					a[i][j]=s[n-1-k];
					k++;
				}
				else a[i][j]=' ';
			}
			else a[i][j]=s[k++];
		} 
	for(int i=0;i<n1;i++)
	{
		for(int j=0;j<n2;j++)
		{
			cout<<a[i][j];
		}
		cout<<endl;
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值