1032 Sharing (25 分)-PAT甲级

To store English words, one method(方法) is to use linked lists(链表) and store a word letter by letter. To save some space, we may let the words share the same sublist(子列表) if they share the same suffix(后缀). For example, loading and being are stored as showed in Figure(图形) 1.

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

 思路:1.通过遍历链表,将结点地址按顺序存到两个数组中,从后往前比对地址,如果不相同就返回最后比对的相同地址,如果不存在相同的结点地址,就输出-1。

            2.以数组来构成哈希表,通过下标查询data,next。

            3.注意地址由五位数字构成,不足五位要补零:cout<<setw(5)<<setfill('0")<<输出内容

AC代码

#include <iostream>
#include <vector>
#include <iomanip>
using namespace std;
int main()
{
	int head1,head2,n;
	int next[100000],temp;
	char data[100000];
	cin>>head1>>head2>>n;
	for(int i=0;i<n;i++)
	{
		cin>>temp;
		cin>>data[temp]>>next[temp];
	}
	vector<int>a1,a2;
	while(head1!=-1)
	{
		a1.push_back(head1);
		head1=next[head1];
	}
	while(head2!=-1)
	{
		a2.push_back(head2);
		head2=next[head2];
	}
	int k=0;
	int len=a1.size()>a2.size()?a2.size():a1.size();
	while(len-k>0)
	{
		if(a1[a1.size()-k-1]!=a2[a2.size()-k-1])
			break;
		k++;
	}
	if(k==0)
		cout<<"-1";
	else
		cout<<setw(5)<<setfill('0')<<a1[a1.size()-k];
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值