1032 Sharing-PAT甲级

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

采用静态链表的写法,将第一个链表出现的地址存入map中,将第二个链表出现的地址与第一个进行比较,如果第二个的地址在第一个链表中出现过,则此地址就是链表的公共后缀的最开始的部分

注意:如果输出的结果不是-1,则需要输出5位数,不够高位补0

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int max_num=100010;
struct Node{
	char data;
	int next;
}node[max_num];
map<int,int>mp;
int main(){
	int res=-1;
	int ad1,ad2,n;
	cin>>ad1>>ad2>>n;
	for(int i=1;i<=n;i++){
		int address;
		char ch;
		int next;
		cin>>address;
		cin>>node[address].data>>node[address].next;
	}
	int p=ad1;
	while(p!=-1){
		mp[p]=1;
		p=node[p].next;
	}
	int q=ad2;
	while(q!=-1){
		if(mp.find(q)!=mp.end()){
			res=q;
			break;
		}
		q=node[q].next;
	}
	if(res==-1)
		cout<<res<<endl;
	else{
		printf("%05d\n",res);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值