1066 Root of AVL Tree-PAT甲级

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

 题目大意:给出一颗AVL树的结点插入顺序的序列,求出该AVL树的根节点

 思路:按照给出AVL树插入顺序的序列直接建立AVL树即可,具体操作可见二叉平衡树(AVL树)

具体包括AVL树的结构体定义,新建结点,获得树高,更新树高,左旋,右旋,获得平衡因子,插入结点等操作

AC代码

#include <iostream>
using namespace std;
struct tree {
	int height;
	int data;
	tree* lchild;
	tree* rchild;
};
tree* newroot(int data) {
	tree* root = new tree;
	root->lchild = root->rchild = NULL;
	root->data = data;
	root->height = 1;
	return root;
}
int getHeight(tree* root) {
	if (root == NULL) {
		return 0;
	} else {
		return root->height;
	}
}
void updateHeight(tree* root) {
	root->height = max(getHeight(root->lchild), getHeight(root->rchild)) + 1;
}
int getBF(tree* root) {
	return getHeight(root->lchild) - getHeight(root->rchild);
} 
void L(tree* &root) {
	tree* temp;
	temp = root->rchild;
	root->rchild = temp->lchild;
	temp->lchild = root;
	updateHeight(root);
	updateHeight(temp);
	root = temp;
}
void R(tree* &root) {
	tree* temp;
	temp = root->lchild;
	root->lchild = temp->rchild;
	temp->rchild = root;
	updateHeight(root);
	updateHeight(temp);
	root = temp;
}
void insert(tree* &root, int data) {
	if (root == NULL) {
		root = newroot(data);
		return;
	}
	if (data < root->data) {
		insert(root->lchild, data);
		updateHeight(root);
		if (getBF(root) == 2) {
			if (getBF(root->lchild) == 1) {
				R(root);
			} else if (getBF(root->lchild) == -1) {
				L(root->lchild);
				R(root);
			}
		}
	} else {
		insert(root->rchild, data);
		updateHeight(root);
		if (getBF(root) == -2) {
			if (getBF(root->rchild) == -1) {
				L(root);
			} else if (getBF(root->rchild) == 1) {
				R(root->rchild);
				L(root);
			}
		}
	}
}
int main() {
	int n;
	cin >> n;
	tree* root = NULL;
	while (n--) {
		int data;
		cin >> data;
		insert(root, data);
	}
	cout << root->data;
	return 0;
}


更多PAT甲级题目:请访问PAT甲级刷题之路--题目索引+知识点分析(正在进行),感谢支持!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值