sort by age(vector)

问题 B: sort by age

题目描述
You are given the ages (in years) of all people of a country with at least 1 year of age. You know that no individual in that country lives for 101 or more years. Now, you are given a very simple task of sorting all the ages in ascending order.
输入格式
There are multiple test cases in the input file. Each case starts with an integer n (0<n<=2000000), the total number of people. In the next line, there are n integers indicating the ages. Input is terminated with a case where n = 0. This case should not be processed.
输出格式
For each case, print a line with n space separated integers. These integers are the ages of that country sorted in ascending order.
输入样例
5
2 1 4 3 6
3
2 1 3
0
输出样例
1 2 3 4 6
1 2 3
ssn:刚学完八大排序留的作业题,这个数据范围应该是用冒泡会超时,随便用种高级排序就可以。虽然我都没有用,我大概其会用优先队列排完之后在导入一个栈再输出,然后还是学习了点更高级的东西hhhh

#include<bits/stdc++.h>
using namespace std;

int main()
{
    int n;
    while(cin>>n){
        if(n==0) break;
        vector<int> a;
        for(int i=0;i<n;i++){
            int x;
            cin>>x;
            a.push_back(x);
        }
        sort(a.begin(),a.end());
        vector<int>::iterator it;
        for(it=a.begin();it!=a.end();it++){
            cout<<*it<<" ";
        }
        cout<<endl;
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

菜·肉多多·狗

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值