7-40 检查密码
本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。
输入格式:
输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。
注意: 题目保证不存在只有小数点的输入。
输出格式:
对每个用户的密码,在一行中输出系统反馈信息,分以下5种:
- 如果密码合法,输出
Your password is wan mei.
; - 如果密码太短,不论合法与否,都输出
Your password is tai duan le.
; - 如果密码长度合法,但存在不合法字符,则输出
Your password is tai luan le.
; - 如果密码长度合法,但只有字母没有数字,则输出
Your password needs shu zi.
; - 如果密码长度合法,但只有数字没有字母,则输出
Your password needs zi mu.
。
输入样例:
5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6
输出样例
Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
这道题我用了字符串的来写,刚开始有一个点一直没过,后来才发现题目说的非空字符串可能是包括了空格,而如果cin>>s的话读不到空格。😞😞😞 所以需要改用getline。
AC代码
#include<bits/stdc++.h>
using namespace std;
bool judge(char ch) //判断字符是否是非法字符
{
if ((ch > 'z' || ch < 'A') && (ch > '9' || ch < '0') && ch != '.') return false;
else
return true;
}
int main()
{
int N;
cin >> N;
getchar();
for (int i = 1; i <= N; i++)
{
string s;
getline(cin,s);
if (s.size() < 6)
{
cout << "Your password is tai duan le.\n";
continue;
}
bool flag=true;
for (int j = 0; j < s.size(); j++)
{
if (!judge(s[j]))
{
flag = false;
cout << "Your password is tai luan le.\n";
break;
}
}
if (!flag) continue;
string s1=s;
for (string::iterator it=s1.begin();it!=s1.end();)
{
if (((*it) >= 'A' && (*it) <= 'z') || (*it) == '.')
{
s1.erase(it);
continue;
}
it++;
} //把是字母和小数点的字符全部删除后如果字符串为空则没有数字
if (s1.empty())
{
cout << "Your password needs shu zi.\n";
continue;
}
string s2 = s;
for (string::iterator it = s2.begin(); it != s2.end();)
{
if (((*it) >= '0' && (*it) <= '9') || (*it) == '.')
{
s2.erase(it);
continue;
}
it++;
} //同理,把是数字和小数点的字符全部删除后如果字符串为空则缺少字母
if (s2.empty())
{
cout << "Your password needs zi mu.\n";
continue;
}
cout << "Your password is wan mei.\n";
}
return 0;
}
学到了将一个字符串从头到尾逐个删除符合一定条件的字符。需要注意的是删除一个字符之后该字符后面的字符地址将会发生变化。