1161 Merging Linked Lists(40行代码+超详细注释+测试点34分析)

分数 25

全屏浏览题目

切换布局

作者 陈越

单位 浙江大学

Given two singly linked lists L1​=a1​→a2​→⋯→an−1​→an​ and L2​=b1​→b2​→⋯→bm−1​→bm​. If n≥2m, you are supposed to reverse and merge the shorter one into the longer one to obtain a list like a1​→a2​→bm​→a3​→a4​→bm−1​⋯. For example, given one list being 6→7 and the other one 1→2→3→4→5, you must output 1→2→7→3→4→6→5.

Input Specification:

Each input file contains one test case. For each case, the first line contains the two addresses of the first nodes of L1​ and L2​, plus a positive N (≤105) which is the total number of nodes given. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is a positive integer no more than 105, and Next is the position of the next node. It is guaranteed that no list is empty, and the longer list is at least twice as long as the shorter one.

Output Specification:

For each case, output in order the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 01000 7
02233 2 34891
00100 6 00001
34891 3 10086
01000 1 02233
00033 5 -1
10086 4 00033
00001 7 -1

Sample Output:

01000 1 02233
02233 2 00001
00001 7 34891
34891 3 10086
10086 4 00100
00100 6 00033
00033 5 -1

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

注意:题目所给的n并不是两个链表的总结点数,其中可能存在一写冗余结点,这会导致测试点34超时或错误

#include<bits/stdc++.h>
using namespace std;
const int N=100010;
int a1,a2,n,add,da,ne,cur,cur2,k1,k2,cnt;
int main(){
    cin>>a1>>a2>>n;
    int data[N],next[N],list[N],list2[N],res[N];//分别记录数据,下一个节点地址,第一个链表,第二个链表,最后合并的链表 
    for(int i=0;i<n;i++){//输入 
        scanf("%d%d%d",&add,&da,&ne);
        data[add]=da,next[add]=ne;
    }
    while(a1!=-1){//将第一个链表的所有地址保存在list中 
        list[cur++]=a1;
        a1=next[a1];
    }
    while(a2!=-1){//将第二个链表的所有地址保存在list2中
        list2[cur2++]=a2;
        a2=next[a2];
    }
    int node_num=cur+cur2;//结点总数是cur+cur2,不是n,因为可能存在一些冗余结点 
    if(cur>=2*cur2){//若第一个链表多 
        reverse(list2,list2+cur2);//反转第二个链表 
        while(cnt<node_num){//保存在res中 
            if(k1<cur)res[cnt++]=list[k1++];
            if(k1<cur)res[cnt++]=list[k1++];
            if(k2<cur2)res[cnt++]=list2[k2++];
        }
    }
    else{//若第二个链表多 
        reverse(list,list+cur);//反转第一个链表 
        while(cnt<node_num){//保存在res中 
            if(k2<cur2)res[cnt++]=list2[k2++];
            if(k2<cur2)res[cnt++]=list2[k2++];
            if(k1<cur)res[cnt++]=list[k1++];
        }
    }
    for(int i=0;i<node_num-1;i++)printf("%05d %d %05d\n",res[i],data[res[i]],res[i+1]);//输出前节点总数-1个结点 
    printf("%05d %d -1\n",res[node_num-1],data[res[node_num-1]]);//单独输出最后一个结点 
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值