The Pilots Brothers‘ refrigerator高效贪心算法

     Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

      Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

      Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

高效贪心算法

AC代码

 
#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>

using namespace std;

int num=0x3f3f3f3f;
int a[10][10],b[10][10],flag;
int fanzhuan(int x,int y)
{
a[x][y]=!a[x][y];
for(int i=0; i<4; i++)
a[x][i]=!a[x][i];

for(int j=0; j<4; j++)
a[j][y]=!a[j][y];
}
int panduan()
{
for(int i=0; i<4; i++)
for(int j=0; j<4; j++)
if(!a[i][j])
return 0;
return 1;
}
struct node
{
int a,b;
} p[20];
void DFS(int x,int y,int ans)//将所有的num步的情况都跑一遍判断是否有符合的
{
if(num==ans)
{
flag=panduan();
return ;
}

if(flag||x>=4||y>=4)
return ;

int fy=(y+1)%4; //按行移动的
int fx=x+(y+1)/4;

fanzhuan(x,y);
DFS(fx,fy,ans+1);
p[ans].a=x;
p[ans].b=y;
fanzhuan(x,y);//原路返回
DFS(fx,fy,ans);

}
int main()
{
string s[4];
while(cin>>s[0])
{
for(int i=1; i<4; i++)
cin>>s[i];
for(int i=0; i<4; i++)
for(int j=0; j<4; j++)//格式转换
if(s[i][j]=='+')
a[i][j]=0;
else
a[i][j]=1;
flag=0;
for(int i=0; i<=16; i++)//枚举
{
num=i;
DFS(0,0,0);
if(flag)
break;
}
cout<<num<<endl;
for(int i=0; i<num; i++)
cout<<p[i].a+1<<" "<<p[i].b+1<<endl;
}
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
网络流算法可以用来解决最大流最小割问题,而飞行员配对问题可以转化成最大流问题。下面是一个基于 Python 的网络流算法求解飞行员配对方案问题的示例代码: ```python from collections import defaultdict class Graph: def __init__(self): self.graph = defaultdict(dict) def add_edge(self, u, v, w): self.graph[u][v] = w def bfs(self, s, t, parent): visited = set() queue = [s] visited.add(s) while queue: u = queue.pop(0) for v in self.graph[u]: if v not in visited and self.graph[u][v] > 0: queue.append(v) visited.add(v) parent[v] = u return True if t in visited else False def max_flow(self, source, sink): parent = {} max_flow = 0 while self.bfs(source, sink, parent): path_flow = float('inf') s = sink while s != source: path_flow = min(path_flow, self.graph[parent[s]][s]) s = parent[s] max_flow += path_flow v = sink while v != source: u = parent[v] self.graph[u][v] -= path_flow self.graph[v][u] += path_flow v = parent[v] return max_flow def pilot_pairing(pilots, planes): num_pilots = len(pilots) num_planes = len(planes) graph = Graph() source = 's' sink = 't' for i in range(num_pilots): graph.add_edge(source, 'P{}'.format(i), 1) for j in range(num_planes): if pilots[i][0] <= planes[j][0] and pilots[i][1] >= planes[j][1]: graph.add_edge('P{}'.format(i), 'A{}'.format(j), 1) graph.add_edge('A{}'.format(i), sink, 1) return graph.max_flow(source, sink) # 示例用法 pilots = [(1, 5), (2, 4), (3, 6), (2, 5)] planes = [(1, 4), (2, 5), (3, 6)] print(pilot_pairing(pilots, planes)) # 输出为 3 ``` 在上面的示例代码中,我们定义了一个 `Graph` 类来表示图,其中 `add_edge` 方法用于添加边,`bfs` 方法用于执行广度优先搜索,`max_flow` 方法用于计算最大流。 在 `pilot_pairing` 函数中,我们首先创建了一个 `Graph` 对象,然后为源点和汇点分别添加一条边,并遍历所有的飞行员和飞机,如果某个飞行员可以驾驶某个飞机,则在他们之间添加一条边。最后调用 `max_flow` 方法计算最大流。 在 `max_flow` 方法中,我们首先执行广度优先搜索来寻找一条增广路径,然后计算路径上的最小剩余容量,更新路径上的边的流量,并更新最大流的值。重复执行这个过程,直到没有增广路径为止。最后返回最大流的值。 在上面的示例中,我们输入了 4 个飞行员和 3 个飞机,输出得到了最大流为 3,说明有 3 对飞行员和飞机可以配对成功。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不吃鸳鸯锅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值