PTA甲级 1058 A+B in Hogwarts(C++)

该篇文章是一个关于编程的挑战,要求编写程序解决哈利波特魔法世界中的货币加法问题。输入是两个货币值A和B,分别由Galleon、Sickle和Knut组成,程序应计算它们的和并按相同格式输出。提供的C++代码示例处理了不同单位之间的进位规则。
摘要由CSDN通过智能技术生成

准大二小白在学技术的同时每天至少一道算法题,以此督促自己,共勉!

1058 A+B in Hogwarts

分数 20

全屏浏览题目

切换布局

作者 CHEN, Yue

单位 浙江大学

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std;
int g[3],s[3],k[3];
int sumG,sumS,sumK;
//17 s - 1 g
//29 k - 1 s
//g s k
int main(){
    scanf("%d.%d.%d %d.%d.%d",&g[1],&s[1],&k[1],&g[2],&s[2],&k[2]);   
    //对K
    if(k[1]+k[2]<29){
        sumK=k[1]+k[2];
    }
    else{
        sumK=k[1]+k[2]-29;
        sumS++;
    }
    //对S
    if(s[1]+s[2]+sumS<17){
        sumS+=s[1]+s[2];
    }
    else{
        sumS+=s[1]+s[2]-17;
        sumG++;
    }
    //对G
    sumG+=g[1]+g[2];
    printf("%d.%d.%d",sumG,sumS,sumK); 
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Silver Vortex

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值