PTA 甲级 1001 A+B Format(C++)

准大二小白在学技术的同时每天至少一道算法题,以此督促自己,共勉!

1001 A+B Format

分数 20

全屏浏览题目

切换布局

作者 CHEN, Yue

单位 浙江大学

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<iostream>
using namespace std;
const int N = 100010;
int p[N];
int main(){
    int a,b,c;
    bool flag;
    cin>>a>>b;
    c = a+b;
    if(c>=0){
        flag=1;
    }else{
        flag=0;
        c=-c;
    }
    if(c==0){
        cout<<0;
        return 0;
    }
    int temp=c,i=0;
    while(temp>0){
        p[i++]=temp%10;
        temp/=10;
    }
    if(flag==0){
        cout<<"-";
    }
    int k=i;
    for(int j=i-1;j>=0;j--){
        cout<<p[j];
            k--;
        if(k%3==0&&k!=0){
            cout<<",";
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Silver Vortex

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值