PTA 1025 PAT Ranking(25分)

1025 PAT Ranking

分数 25

全屏浏览题目

切换布局

作者 CHEN, Yue

单位 浙江大学

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

代码长度限制

16 KB

时间限制

300 ms

内存限制

64 MB

好久没做题(o(╥﹏╥)o),继续坚持吧

#include<bits/stdc++.h>
using namespace std;
struct student{
    char name[14];
    int score;
    int frln;
    int fn;
    int lr;
}stu[100010];
bool cmp(student a,student b){
    if(a.score != b.score)
    return a.score > b.score;
    int result = strcmp(a.name,b.name);
     return result < 0;
}
int main(){
    int flag = 0;//标识第几个阵营
    int sum = 0;//统计总共多少学生
    int n,k;
    cin>>n;
    while(n--){
        int rank = 1;
        cin>>k;
        int index = sum;
        sum+=k;
        flag++;
        for(int i = index; i< k + index; i++){
            cin >> stu[i].name>>stu[i].score;
            stu[i].fn = flag;
        }
        sort(stu+index,stu+k+index,cmp);
        stu[index].lr = 1;
        for(int i = index+1; i< k + index; i++){
            if(stu[i].score==stu[i-1].score){
                stu[i].lr=stu[i-1].lr;
            }else{
            stu[i].lr = i - index +1;
            }
        }
    }
    // int rank = 0;//final_rank
    sort(stu,stu+sum,cmp);
    stu[0].frln = 1;
    for(int i = 1;i < sum; i++){
        if(stu[i].score == stu[i-1].score){
            stu[i].frln = stu[i-1].frln;
        }else{
            stu[i].frln = i+1;
        }
    //index1是所有的,index2是每个分开
    }
    printf("%d\n",sum);
    for(int i = 0;i < sum; i++){
        printf("%s %d %d %d\n",stu[i].name,stu[i].frln,stu[i].fn,stu[i].lr);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Silver Vortex

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值