PTA 甲级 1005 Spell It Right(C++)

准大二小白在学技术的同时每天至少一道算法题,以此督促自己,共勉!

1005 Spell It Right

分数 20

全屏浏览题目

切换布局

作者 CHEN, Yue

单位 浙江大学

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

​
#include<iostream>
#include<map>
#include<string>
using namespace std;
const int N=100010;
long long int a[N];
int main(){
    long long int sum=0,temp=0;
    string str;
    cin>>str;
    map<int, string> myMap {
        {0, "zero"},
        {1, "one"},
        {2, "two"},
        {3, "three"},
        {4, "four"},
        {5, "five"},
        {6, "six"},
        {7, "seven"},
        {8, "eight"},
        {9, "nine"},
    };
    for(int i=0;i<str.size();i++){
        sum+=str[i]-'0';
    }
    temp=sum;
    int k=0;
    //测试点2
    if(sum==0)a[k++]=0;
    // cout<<sum<<endl;
    while(temp){
        a[k++]=temp%10;
        temp/=10;
    }
    // a[0]=5,a[1]=1 k
    for(int j=k-1;j>=0;j--){
        cout<<myMap[a[j]];
        if(j!=0)
            printf(" ");
    }
    return 0;
}

​

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Silver Vortex

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值