PTA 甲级 1035 Password(C++)

该程序旨在检查并修改PAT账号中可能引起混淆的密码,如将1替换为@,0替换为%,l替换为L,O替换为o。它读取输入的账号信息,对每个账号进行处理,并输出需要修改的账号及其新密码。如果没有任何账号需要修改,程序会给出相应的提示。
摘要由CSDN通过智能技术生成

准大二小白在学技术的同时每天至少一道算法题,以此督促自己,共勉!

1035 Password

分数 20

全屏浏览题目

切换布局

作者 CHEN, Yue

单位 浙江大学

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

// 1--@
// 0--%
// l --l
// O by o
#include<bits/stdc++.h>
using namespace std;
struct person{
    char user[11];
    char account[11];
    int flag;//标记是否已被修改
}p[1001];
int N,len,temp;//len为单个account长度,temp为有问题的字符串数量,
//最后只需判断temp是否为0即可
int main(){
    cin>>N;
    for(int i=0;i<N;i++){
        scanf("%s %s",p[i].user,p[i].account);
        len=strlen(p[i].account);
        for(int j=0;j<len;j++){
            if(p[i].account[j]=='1'){
                p[i].account[j]='@';
                p[i].flag=1;
                continue;
            }
            if(p[i].account[j]=='0'){
                p[i].account[j]='%';
                p[i].flag=1;
                continue;
            }
            if(p[i].account[j]=='l'){
                p[i].account[j]='L';
                p[i].flag=1;
                continue;
            }
            if(p[i].account[j]=='O'){
                p[i].account[j]='o';
                p[i].flag=1;
                continue;
            }
        }
        if(p[i].flag){
            temp++;
        }
    }
    //如果一个都没有
    if(temp==0){
        if(N==1)
            printf("There is 1 account and no account is modified\n");
        else printf("There are %d accounts and no account is modified\n",N);
    }
    else{
        printf("%d\n",temp);
        for(int i=0;i<N;i++){
            if(p[i].flag==1){
                printf("%s %s\n",p[i].user,p[i].account);
            }          
        }
    }
    return 0;
}

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Silver Vortex

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值