有向图的拓扑序列—BFS遍历图

输入样例:

3 3
1 2
2 3
1 3

输出样例:

1 2 3
#include<bits/stdc++.h>
using namespace std;
const int N = 1e6 + 10;
int h[N], ne[N], e[N], idx;//邻接表存储图
int in[N];
int q[N], tt = -1,hh=0;
int n, m;
void add(int a, int b) {
	e[idx] = b;
	ne[idx] = h[a];
	h[a] = idx++;
}
void topology() {
	for (int i = 1;i <= n;i++) {
		if (in[i] == 0) {
			q[++tt] = i;
		}
	}
	while (hh <= tt) {
		int now = q[hh++];
		for (int i = h[now];i != -1;i = ne[i]) {
			int j = e[i];
			in[j]--;
			if (in[j] == 0) {
				q[++tt] = j;
			}
		}
	}
	if (tt == n - 1) {
		for (int i = 0;i <= tt;i++) {
			cout << q[i] << ' ';
		}
	}
	else cout << -1;
}
int main() {
	cin >> n >> m;
	memset(h, -1, sizeof h);
	for (int i = 0;i < m;i++) {
		int a, b;
		cin >> a >> b;
		add(a, b);
		in[b]++;
	}
	topology();
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ou_fan

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值